Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Массив целых чисел 30 элементов. найти количество значения которых больше число А. на паскале

5-9 класс

Dianco 31 авг. 2013 г., 15:23:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
школьник123445
31 авг. 2013 г., 16:44:06 (10 лет назад)

var

  arr : array [1..30] of integer;

  i, a, c : integer;

begin

  writeln ('Введите массив');

  for i := 1 to 30 do read (arr[i]);

  writeln ('Введите A');

  read (a);

  c := 0;

  for i := 1 to 30 do

    if arr[i] > a then inc (c);

  writeln (c);

end.

Ответить

Другие вопросы из категории

1.Составьте программу заполнения массива НЕ ИСПОЛЬЗУЯ КЛАВИАТУРУ числами -2, 4,-6,8,-10...20.

2.Сформировать одномерный массив из 30 элементов (задаются ГСЧ-рандомно) из интервала -3..3. Массив вывести.Найти номер положительных элементов и их сумму чисел.

Срочно нужна помощь!!

1. С клавиатуры вводят слово и символ. Составть программу, которая:
а) проверяет, есть ли в этом слове заданный символ;
б) определяет позицию заданного символа;
в) подсчитывает количество вхождений заданного символа.
2. С клавиатуры вводят строку и слово. Составть программу, которая:
а) определяет позицию заданного слова;
б) удаляет заданное слово;
в) вставляет в строку заданное слово.
3. Составть программу, которая:
а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси;
б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.
4. Составть программу, которая:
а) в строке "край озер" добавляет слова "лесов и рек";
б) в строке "я учусь в школе" заменить слова "в школе" на "в 10-ом классе".
5. Составть программу, которая переставляет на первое место:
а) в строке "моя родина Беларусь" слово "Беларусь";

б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в

предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет



Вы находитесь на странице вопроса "Массив целых чисел 30 элементов. найти количество значения которых больше число А. на паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.