Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится натуральное число : если это число четырехзначное то выяснить является ли последовательность цифр от старшего к младшему арифметич

10-11 класс

последовательностью; если нет то увеличить число в 2 раза

Olyayakovleva97 10 мая 2014 г., 7:09:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
жиз
10 мая 2014 г., 8:18:56 (10 лет назад)

var n:integer;
a,b,c,d:integer; x,y,z:real;
begin
read(n);
if n>999 then begin
a:=n div 1000;
b:=n mod 1000 div 100;
c:=n mod 100 div 10;
d:=n mod 10 div 1;
x:=(a-b);
y:=(b-c);
z:=(c-d);
if a>b then write(n*2) else if (x=y) and (y=z) then write ('Arif posledovatelnost');
if (x<>y) and (y<>z) then write(n*2);
end
else write('Chislo ne 4 znachnoe');
end.

Ответить

Другие вопросы из категории

где можно быстро создать сайт?
Написать программу в VBA:

2 февраля вкладчик положил на счет в банке 2000 грн. (PV) под 25% годовых (r) (схема обыкновенный процент и приблизительное число дней). По какое число нужно делать вклад, чтобы получить 3550 грн. (FV)? Длительность года по схеме приблизительное число дней будет 360. t=(FV/PV-1)*T/r; t-число финансовой операции, T-длительность года.
Очень нужно, пожалуйста...

Читайте также

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

1)Стороны прямоугольника параллельны осям координат.Одна из вершин имеет координаты (0,0),координаты противоположной вершины задаются с

клавиатуры.Вычислите площадь прямоугольника. 2)С клавиатуры вводится натуральное число.Если оно кратно двум,напишите "четное число",иначе напишите "нечетное число".



Вы находитесь на странице вопроса "Вводится натуральное число : если это число четырехзначное то выяснить является ли последовательность цифр от старшего к младшему арифметич", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.