Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С помощью Паскаля: Число в двоичной системе счисления, введенное

10-11 класс

пользователем программы, преобразовать в десятичное число.
Используя цикл! Желательно попроще (без length, ord, exp).

AnelyaAnuarova 17 февр. 2014 г., 8:37:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Laymova
17 февр. 2014 г., 11:20:07 (10 лет назад)

var
  a, b, i: integer;
  d: string;
  
begin
  readln(a);
  d := a.ToString();
  for i := length(d) downto 1 do
    b += byte.Parse(d[i]) * round(power(2, length(d) - i));
  writeln(b);
end.

Незя без length, нерационально

Ответить

Другие вопросы из категории

Ребят помогите программу дописать по vba: в общем нужно сделать матрицу с рандомными числами, найти наименьшее число в ней, и сделать другую матрицу на

порядок меньше, с вычеркнутым столбцом и строкой на пересечении которых находится наименьшее число из первой матрицы. Я нашел наименьшее число, а как дольше делать понять не могу.
Вот начало самой программы:
Sub laba9()
Dim N As Integer, a() As Integer, i As Byte, j As Byte, min As Integer, l1 As Integer, l2 As Integer
N = Val(InputBox("Введите размерность массива"))
ReDim a(N, N)
Sheets("Лист1").Select
Sheets("Лист1").Range("A1:AAA100").Clear
For i = 1 To N
For j = 1 To N
a(i, j) = Rnd * 100
Cells(i, j) = a(i, j)
Next j
Next i
min = a(1, 1)
l1 = 1
l2 = 2
For i = 1 To N
For j = 1 To N
If a(i, j) < min Then
min = a(i, j)
l1 = i
l2 = j
End If
Next j
Next i
End sub

Читайте также

1.Переведите числа 25, 31, 37, 63, 85, 127, 128 в двоичную систему счисления.

2. Переведите числа 1000112, 1011012, 1101112, 10010112, 10111112, 11010012 в десятичнуюсистему счисления.
3. Сколько единиц в двоичной записи чисел 173, 195, 126, 208?
4. Сколько значащих нулей в двоичной записи чисел 48, 73, 96, 254?
5. Как по записи числа в двоичной системе счисления определить, что оно – четное? делитсяна 4? на 8? на 32?
6. Выполните сложение в двоичной системе:а) 10101112 + 1101012б) 10101112 + 1101012в) 1011012 + 111112г) 101112 + 1011102д) 1110112 + 110112е) 1110112 + 100112Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
7. Выполните вычитание в двоичной системе:а) 1011012 – 111112б) 110112 – 1101012г) 1010112 – 110112д) 10112 – 1001012 в) 101112 – 1011102 е) 10012 – 1011012Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
8. Переведите в двоичную систему числа 13,125; 23,25; 37,375; 48,625; 78,875.
9. Переведите в двоичную систему числа 11,8; 15,3; 22,7, выделив период в дробной части.
10. Требуется проверить, верно ли, что среднее арифметическое 100 целых чисел превышает0,2. Как сделать это, не используя операции с дробными числами?

1)Дано : a=F716 , b= 3718 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?

А) 111110012 Б) 110110002 В) 111101112 Г) 111110002
2)Дано : a= DD16 , b = 3378 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110110102 Б) 111111102 В) 110111102 Г) 110111112
3)Дано : a=EA16 , b = 3548 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111010102 Б) 111011102 В) 111010112 Г) 111011002
4)Дано : a=3228 , b =D416 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А) 110100112 Б) 110011102 В) 110010102 Г) 110011002
5)Дано : a= D116 , b= 3338 . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству aC b ?
А)111000112 Б) 110110102 В) 101011012 Г) 110111012
ПОМОГИТЕ ПОЖАЛУЙСТА!

1.чему равна сумма десятичного числа10 и двоичного числа 10 в десятичной системе счисления

1)20
2)12
3)21
4)1010
число 12 десятичной системы счисления в двоичной системе счисления имеет вид:
1)1000
2)1011
3)0010
4)0100
5)1100



Вы находитесь на странице вопроса "С помощью Паскаля: Число в двоичной системе счисления, введенное", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.