Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

среда turbo pascal. если не сложно, то составьте программу перевода из восьмеричной системы счисления в десятеричную

5-9 класс

Вандалковская 30 окт. 2016 г., 3:45:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aanddr
30 окт. 2016 г., 6:14:27 (7 лет назад)

var
  number, i : integer;
  sum : real;
begin
  write('Введите число: ');
  readln(number);
  sum := 0;  i := 0;
  while number > 0 do
  begin
    sum := sum + number mod 10 * Power(8, i); //Или вместо Power(8, i) - exp(ln(8) * i)
    i := i + 1;
    number := number div 10;
  end;
  writeln('Результат: ', sum);
end.

+ 0 -
333ccc
30 окт. 2016 г., 6:54:21 (7 лет назад)

poprobuj poiskat v inete gotovyj kod. Typa "konvertacija sistem schislenija pascal"

+ 0 -
Sergeyfdv
30 окт. 2016 г., 8:54:54 (7 лет назад)

искал. программа не выполняется

+ 0 -
Jokerrr588
30 окт. 2016 г., 10:37:38 (7 лет назад)

vylozhy kod v zadanii. ispravit legche chem pisat zanovo

+ 0 -
SFomichev15
30 окт. 2016 г., 11:12:03 (7 лет назад)

function ToDec(n:string;r:longint):longint;
program a1;
var
m,i:longint;
const
digit:string[8]='01234567';
begin
m:=0;
while n[1]='0' do
delete(n,1,1);
for i:=1 to length(n) do
m:=m*r+pos(n[i],digit)-1;
ToDec:=m;
end;

Ответить

Другие вопросы из категории

2. В январе 1 кг картофеля, 1 л молока, 1 дес. яиц стоили по A руб. (A - произвольное и может меняться). Ежемесячно цена картофеля увеличивается на

0,5% по отношению к предыдущему месяцу, цена молока - на 2%, цена яиц - на 1%. Описать таблицу, в которой будет прослеживаться ежемесячное изменение цены каждого продукта в течение двух кварталов с января по июнь (в режиме отображения формул).

Помогите

Мощность алфавита =64. Сколько Кбайт памяти потребуется, чтобы сохранить 128 страниц текста, содержащего в среднем 256 символов на каждой странице?

Читайте также

№1 Семенова Анастасия 1. Закодировать свои имя и фамилию следующим образом: А = 1, Б = 2, В = 3, ….. , Ю = 32, Я = 33.

2. Найти сумму ГЛАСНЫХ букв своей фамилии.
3. Найти сумму СОГЛАСНЫХ букв своего имени.
4. Перевести сумму букв фамилии ИЗ ДЕСЯТИЧНОЙ СС В ДЕВЯТИРИЧНУЮ СС
5. Перевести сумму букв имени ИЗ ДЕСЯТИЧНОЙ СС В ДВЕНАДЦАТИРИЧНУЮ СС.

6. Найти сумму букв своей фамилии по алгоритму от 22.04.2013г.
7. Возвести в степень 3/2 полученное число.
8. Целую часть полученного десятичного числа перевести последовательно в 2-ную, 3-ную, 7-ную, 12-ную и 16-ную системы счисления.
9. Сделать вывод на основе полученых результатов.

№2На языке программирования Паскаль составить программу перевода из десятичной системы счисления в систему счисления с основанием Х,
где Х - целое число, определяемое по такому правилу:
если 2-я буква фамилии учащегося находится в интервале от А до Д, то Х = 9;
если 2-я буква фамилии учащегося находится в интервале от Е до К, то Х = 8;
если 2-я буква фамилии учащегося находится в интервале от Л до Р, то Х = 7;
если 2-я буква фамилии учащегося находится в интервале от С до Ц, то Х = 6;
если 2-я буква фамилии учащегося находится в интервале от Ч до Я, то Х = 5.

Пожалуйста, помогите) Очень важно) Решите хотя бы одну задачу... А если не сложно, то лучше 2 :))) 1) Информационная ёмкость

человеческой яйцеклетки приблизительно равна 2 в 33 степени битов. Сколько дискет ёмкостью 1,4 МБайт потребуется для размещения этой информации ?

2) Дискета объёмом 1440 КБайт весит 20 г. Сколько будет весить набор дискет, необходимый для полногокопирования информации с жёсткого диска объёмом 80 ГБайт ?

Заранее огроооомное спасибо :)

Доброго всем вечера/дня!Пожалуйста,помогите с Информатикой

записать программу в ПАСКАЛЬ(!)
Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет.
И если не сложно,то с подробными объяснениями!!!




Всем заранее спасибо!!!)



Вы находитесь на странице вопроса "среда turbo pascal. если не сложно, то составьте программу перевода из восьмеричной системы счисления в десятеричную", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.