Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)Что необходимо знать при разработке алгоритма?

5-9 класс

2)Перечислите известные вам формы записи алгоритмов?
3)Злая мачеха отправила падчерицу за водой "Вот тебе 2 ведра, в одн из них входит 9 литров воды, а в другое 5 литров. Но ты должна принести домой ровно 3 литра воды",- сказала она бедной девушке.Как должна действовать падчерица, чтобы выполнить это поручение?
4)Какие геометрические фигуры используются в блок-схеме?
5)Каким образом задается порядок выполнения отдельных действий в блок схеме?

Efim236 26 июля 2014 г., 9:12:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Amina1505
26 июля 2014 г., 9:50:02 (9 лет назад)

1)Необходимы: данные задачи, условия, порядок действий.
2)Формы записи алгоритмов: графический (в виде блок-схемы), на естественном языке, на алгоритмическом языке, на языке программирования.
3)1. набрать в 9л-ое ведро полное и вылить из него в 5л-ое. освободить 5л-ое ведро.в 9л-ом останется 4 л.
2. переливает эти 4 л в 5л-ое ведро.
3. наполняет 9л-ое ведро и выливает в 5л-ое ещё 1 л. в 9л-ом остается 8 л. освобождает 5л-ое ведро.
4. переливает из9л-ого ведра 5 л. и в 9л-ом ведре остается ровно 3 л.
4)Геометрические фигуры в блок-схеме: овал - начало и конец алгоритма, прямоугольник - команды, параллелограмм - ввод и вывод данных, ромб - условие, шестиугольник - счетчик цикла.
5)Порядок выполнения отдельных действий в блок схеме задается в виде стрелок, соединяющих блоки.

Ответить

Другие вопросы из категории

1)Какое основное предназначение WWW

2)перечислите основные элементы веб страницы
3)В чем основное отличие гипертекста от обычного

почему программа в pascal ABC выдаёт что массив 0

program peremena;
const N=8;
var A:array[1..N] of integer;
I,X: integer;
begin
for i:=1 to n do
if i>N then
begin
begin
x:=a[i];
a[i]:=a[n];
a[n]:=x
end;
begin
x:=a[i+1];
a[i+1]:=a[n-1];
a[n-1]:=x
end;
end;
writeLn('массив',A[i]:8)
end.

Читайте также

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

помогите пожалуйста!!!! помогите хоть что нибудь пожалуйста!!!! срочно надо!! заранее спасибо!!1 1 Система интерактивного текстового общения в режиме

онлайн 2 программа обеспечивающая доступ к информации 3 Крупный сайт объединяющий различные универсальные сервисы 4 Обращение к информационной системе для получения справки 5 Система имен в интернете 6 Тип локальной сети когда к каждому компьютеру подходит отдельный кабель из одного центрального узла 7 Сеть,объединяющая компьютеры в рамках одной организации 8 Язык общения с различными компьютерными устройствами и программами 9 Программа, подготавливающая запрос пользователя и получающая ответ от узла сети 10 Выделение дискового пространства для хранения и обеспечения работы сайтов 11 Технология позволяющая реализовать переход от одного информационного ресурса к другому 12 Общая схема соединения компьютеров в локальной сети 13 Что позволяет делать с электронными письмами почтовая программа 14 Какой протокол обеспечивает разбиение файлов на IP пакеты в процессе передачи и сборку файлов в процессе получения 15 Современный способ групповой коммуникации 16 Что надо знать для просмотра электронного почтового ящика 17 Рекламное пространство на сайте 18 Множество взаимосвязанных элементов,образующих определенное целостное единство 19 Стандарт,определяющий,например,форму представления и способ пересылки сообщений 20 Центральный компьютер,распределяющий между пользователями общие ресурсы.

1.что вы помните под текстовым документам? 2.что общего и в чём отличие возможностей текстового процессора и текстового редактора?

3.перечислите основные этапы подготовки текстового документа на компютере?

4.какие правила необходимо соблюдать при наборе (вводе) теста?

5.как можно преобрфзовать текста на этапе его редактирования?

6.какие способы перемещения по большому текстовому документу вам известны?

7.для чего необходимо осуществлять форматирование текса? как можно преобрфзовать текст на этом этапе?



Вы находитесь на странице вопроса "1)Что необходимо знать при разработке алгоритма?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.