Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать задачу в Паскале.

5-9 класс

Определить что больше по модулю:сумма отрицательных чисел массива или отрицательных.

Juliajuly31 24 дек. 2014 г., 0:35:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
261511
24 дек. 2014 г., 3:05:48 (9 лет назад)

var 
   a: array[1..10] of integer;
   i, sotr, spol: integer;
begin
writeln('Массив:');
for i := 1 to 10 do
    begin
    a[i] := random(-20,20);
    write(a[i],' ');
    if a[i] > 0 then  spol:=spol+a[i] else sotr:=sotr+a[i]
    end; 
writeln; 
if spol>abs(sotr) then  writeln('Сумма положительных больше');   
if spol<abs(sotr) then  writeln('Модуль суммы отрицательных больше');
end.

DIM A(10)
RANDOMIZE TIMER
FOR I = 1 TO 10
    A(I) = INT(RND * 40) - 20
    PRINT A(I); " ";
    IF A(I) < 0 THEN OT = OT + A(I) ELSE POL = POL + A(I)
NEXT I
PRINT
IF POL > ABS(OT) THEN PRINT "Сумма положительных больше"
IF ABS(OT) > POL THEN PRINT "Модуль суммы отрицательных больше"

Ответить

Читайте также

Как написать задачу в Паскале?

Дано целое трехзначное число N.
Верно ли, что в нем есть хотя бы одна цифра 7?

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Помогите решить задачку в паскале ! Пожалуйста !

Составить программу на языке Pascal для решения следующей логической задачи.
По графику нужно написать задачу и решение, график прилагается.

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.



Вы находитесь на странице вопроса "Написать задачу в Паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.