Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, пожалуйста! Нужно разработать словесные алгоритмы, а также изобразить блок-схему с последующей реализацией на паскале для задачи:

10-11 класс

Алгоритм вычисления по формуле:

Rostyka14 15 июля 2014 г., 9:29:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yuma6
15 июля 2014 г., 11:34:02 (9 лет назад)

Если правильно поняла задачу, на паскале это выглядит так:
var n,b,i,a,c:integer;
begin 
writeln('input n'); readln(n); 
writeln('input a'); readln(a); 
c:=a;
for i:=1 to n do 
begin
 writeln('input b',i);  
readln(b); 
c:=c-b; 
end;
writeln('c=',c);
end.
Алгоритм и блок-схема по имеющейся программе делаются элементарно. 

Ответить

Другие вопросы из категории

Помогите срочно в паскаль abc.

1. Написать программу нахождения среди чисел от 1 до 100 всех пар чисел, для которых их сумма равна их произведению)
2. Написать программу вычисления куба суммы всех четных чисел от 2 до 100
3. Каждая бактерия делится на две через три минуты. В начальный момент имеется одна бактерия. Написать программу, определяющую, сколько будет бактерий через N минут

Используя объявлены типа: type t1 = (золото, медь, серебро, нефть, железо, ртуть, свинец, марганец, уголь, газ) построить пять множеств, состоящих из

различных комбинаций этого списка. Вывести на экран названия объектов, которые есть во всех множествах одновременно. Определить, каких объектов нет ни в одной множестве. Выполнить дополнительно задачи своего варианта, а именно определить, какие объекты: входящие во вторую и третью множества. Паскаль, заранее спасибо

Читайте также

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.



Вы находитесь на странице вопроса "Помогите, пожалуйста! Нужно разработать словесные алгоритмы, а также изобразить блок-схему с последующей реализацией на паскале для задачи:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.