Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны 2 целых трёхзначных числа: a и b. Для каждого числа в интервале от a до b, сумма цифр которого кратна трём, зеркально отразить цифры числа.

10-11 класс

Например: 207 (2+0+7=9). 9 кратно 3. Зеркальное отражение 207 = 702

Дини 11 июня 2013 г., 12:46:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VerkaKerka
11 июня 2013 г., 14:26:51 (10 лет назад)

Если сумма цифр кратна трем, то число делится на 3.

 

var

  a, b, i : integer;

begin

  read (a, b);

  for i := a to b do

    if i mod 3 = 0 then

      writeln (i div 100 + (i div 10 mod 10) * 10 + (i mod 10) * 100);

end.

Ответить

Другие вопросы из категории

выбери точку 480, 115, 555, 160, 220 в котором может допрыгнуть исполнитель кузнечик из начального положения в точке 0, если он умеет выполнять только

команды:
вперед 15- прыгает по числовой оси вперед на 15 единиц, назад 6 - прыгает по числовой оси назад на 6 единиц

Помогите пожалуйста.

Найти значение
переменной К после выполнения программы.

какую папку нельзя создать?
!!! помогите !!! очень !!! срочно !!! 7 класс !!! если что !!!

№11 информационное сообщение объемом 375 байтов состоит из 500 символов. Каков информационный вес каждого символа этого сообщения? Какова мощность алфавита с помощью которого было записано это сообщение

№12 Для записи текста использовался 64-символьный алфавит.
Какое кол-во информации в байтах содержат 3 страницы текста, если на каждой странице расположено 40 строк по 60 символов в строке ?

№13 Сообщение занимает 6 страниц по 40 строк, в каждой строке за-
писано по 60 символов. Информационный объем всего сообщения равен 9000 байтам . Каков информационный вес одного символа? Сколько символов в алфавите языка, на котором записано это сообщение

1)Документ объемом 600 Мб можно передать по сети двумя способами:

А. Сжать архиватором, передать архив по каналу связи, распаковать.

Б. Передать по каналу связи без использования архиватора.

Какой способ быстрее и насколько, если:
Средняя скорость передачи данных по каналу связи составляет 2 в 20 степени бит/с;

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B



Вы находитесь на странице вопроса "Даны 2 целых трёхзначных числа: a и b. Для каждого числа в интервале от a до b, сумма цифр которого кратна трём, зеркально отразить цифры числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.