Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Элементы одномерного массива С(T) получаются расчетом по формуле С(T)= sqrt(T)* tg(2T), где T- позиция элемента в массиве С(T). Определите, какая

10-11 класс

раз-ность двух соседних элементов в этом массиве (1-ый и 2-ой, 2-ой и 3-ий, 3-ий и 4-ый и т.д.) будет являться наименьшей. Сформируйте новый массив T(Y), состоящий из разностей пар элементов массива С(Т).

Kolobrodova200431 30 июля 2016 г., 1:24:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nbelostotskaya
30 июля 2016 г., 1:59:47 (7 лет назад)

Program massiv;
Const N=10;
Var Rmin: integer;
j,i:integer;
C:array[1..N] of real;
T:array[1..2*N]of real;
Begin
For i:=1 to N do Begin
C[i]:=sqrt(i)* sin(2*i)/cos(2*i);
Write(C[i]:5:2, ' ');
End;
writeln('');

For i:=1 to N-1 do begin
T[i]:=C[i+1]-C[i];
T[N+i-1]:=C[i]-C[i+1];
end;

Rmin:=1;
for i:=2 to 2*N-2 do begin
if T[i]<T[Rmin] then
Rmin:=i;
end;

if Rmin<N then
writeln('naimenshaya raznost= ', Rmin+1, ' and ', Rmin, ' elementiv' )
else
writeln('naimenshaya raznost= ', Rmin-N+1, ' and ', Rmin-N+2, ' elementiv' );
end.

Ответить

Другие вопросы из категории

Готовлюсь к ЕГЭ по информатике. Задача простая, но мои мозги ослабли после отдыха и не функционируют.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

var a,b:integer;

begin

a:=8;

b:=-4;

while not (a=2) do

if b>0 then

a:=a div 2

else

begin

a:=a div 2;

b:=-b;

end;

a:=-a+2*b;

write(a);

END.

На языке SQL создать запрос.

Даны табл. Пациенты(код пациента, фамилия, код отделения), Отделения(код отделения, название).
посчитать количество пациентов в терапевтическом отделении

найти наименьший элемент в двумерном массива?
. Абсолютные ссылки при перемещении или копировании в электронной таблице:

А) не изменяются;
Б) преобразуются вне зависимости от нового положения формулы;
В) преобразуются в зависимости от нового положения формулы;
Г) в одних случаях меняются, в других нет.

Читайте также

Создать

массив, каждый элемент которого рассчитывается по формуле: I^2-1, где I – индекс
элемента массива. Вывести полученный
массив на экран, расположив каждый элемент в отдельной строке.

написать программу для вычисления прибыли по формуле P=S1-S1,где S1-сумма,вырученная от продажи,S2-сумма затрат. Если прибыль меньше или равна нулю

вывести надпись "Производство нерентабельно".Значения S1,S2ввести с клавиатуры.

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}




Вы находитесь на странице вопроса "Элементы одномерного массива С(T) получаются расчетом по формуле С(T)= sqrt(T)* tg(2T), где T- позиция элемента в массиве С(T). Определите, какая", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.