Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив строк Нужно отсортировать эти строки в алфавитном порядке (нужна конкретная процедура, конкретный цикл, который это

5-9 класс

сможет сделать).
Помогите, нужно срочно!

Katka1234 11 апр. 2014 г., 20:48:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maykmay
11 апр. 2014 г., 22:23:55 (10 лет назад)

Если я не ошибаюсь, то можно использовать обычную сортировку пузырьком и для строк.
program strsort;
var a:array[1..1000] of string;
i,j,n:integer; r:string;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n-1 do
for j:=i+1 to n do
if a[i]>a[j] then begin r:=a[i]; a[i]:=a[j]; a[j]:=r; end;

for i:=1 to n do
writeln(a[i]);
end.

Попробуй эту, вроде должна работать. 

Ответить

Другие вопросы из категории

Спортсмен-лыжник пробежал в первый день K км. Каждый последующий день он увеличивал длину пробега на P процентов от пробега первого дня. Узнать

после какого дня суммарный пробег лыжника будет больше чем N км. Решить на Паскале.
K, P, N вводятся с клавиатуры

задание 1.информационное сообщение объемом 1,5 кбайта содержит 3072 .сколько символов содержит алфавит,при помощи которого записано это сообщение

зад 2. книга,набранная с помощью компьютера,содержит 150 стр на каждый стр -40 стр ,в каждой строке- 60 символов. каков объем информации в книге?

зад 3 . сообщение занимает 2 стр и содержит 1/16 кбайта информации. на каждой стр записано 256 символов.какова мощность использованного алфавита?

помогите плиз капец как надо ваще не могу решить плиззз

надо решить 10,11,12,13

Читайте также

Сформируйте массив bc размерностью30 элементов случайным образом из диапазона 0 – 50.сформированный массив выведите на экран в строку. Подсчитайте

сумму всех четных элементов массива и отдельно сумму элементов имеющих четные индексы. Выведите результаты подсчета на экран. Отсортируйте данный массив по убыванию.

Дана некоторая строка . Из нее создают вторую строку по следующему алгоритму:

1. Сначала вторая строка пуста
2.Затем каждый символ первой строки от первого до последнего приписывается к создаваемой(второй) строке слева , если это гласная буква и ее позиция в исходной строке была нечетной , или если это согласная буква и ее позиция была четной. Во всех остальных случаях очередной символ первой строки приписывается ко второй строке справа . По этому алгоритму строка ВОЦА превратилась в строку ОВЦА .
А какая строка превратилась в строку ИНАВОРИГОРПРАМЕ ??

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "Дан массив строк Нужно отсортировать эти строки в алфавитном порядке (нужна конкретная процедура, конкретный цикл, который это", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.