Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано натуральное число. Определить: 1) Определить количество повторений заданной цифры в нем 2) Сколько раз в нем встречается цифра, равная последней

10-11 класс

3) Количество четных цифр в нем.

желательно в Basic. но можно и паскаль

Damir62 24 сент. 2014 г., 3:27:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bog1
24 сент. 2014 г., 6:18:54 (9 лет назад)

var a,c,l,w1,w2,w3 : longint;

begin

  readln(a,c);

  w1:=0;

  w2:=0;

  w3:=0;

  l:=a mod 10;

  while a>0 do

  begin

     if a mod 10=c then w1:=w1+1;

     if a mod 10=l then w2:=w2+1;

     if a mod 2=0 then w3:=w3+1;

     a:=a div 10;

  end;

  writeln(w1,' ',w2,' ',w3);

end.

Ответить

Другие вопросы из категории

Приведите примеры ситуаций, в которых информация

а)создаётся; б)копируется; в)передаётся; г)обрабатывается; д)воспринимается; е)разрушается; ж)запоминается; з)измеряется; и)ищется; к)делится на части; л)принимается; м)упрощается.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр



Вы находитесь на странице вопроса "Дано натуральное число. Определить: 1) Определить количество повторений заданной цифры в нем 2) Сколько раз в нем встречается цифра, равная последней", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.