Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите пожалуйста программу на языке Паскаль: Дано число. Если оно кратно 3, то увеличить его на 6, в противном случае обнулить.

5-9 класс

CheGevaraaa 24 марта 2017 г., 14:18:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ZAURZAUR2000
24 марта 2017 г., 16:31:25 (7 лет назад)

program blunt;

var x:word;

begin

write('Введите целое число = ');

readln(x);

if( 0 == (x mod 3) ) then x:=x+6; else x:=0;

writeln('Результат = ',x);

end.

+ 0 -
Дильназочка
24 марта 2017 г., 19:19:03 (7 лет назад)

uses crt;

var x:integer;
begin
write('Число = ');
readln(x);
if x mod 3 =0 then x:=x+6 else x:=0;
writeln(x);

readkey;

end.

Ответить

Другие вопросы из категории

Перестановкой из n чисел называется-последовательность чисел,где каждое число от 1 до n встречается ровно один раз.Перестановка b1,b2...bN является

обратной перестановкой перестановки a1,a2...aN, если b[ai]=1=i для каждого i от 1 до n.для заданных двух перестановок определите является ли вторая перестановка обратной первой
Формат входных данных
В певой строке входного файла записано одно целое число n (1<=n<=1000)-размер перестановок.Во второй запписаны n целых чисел b1,b2...bN (1<=bi<=n)-вторая перестановка.
Формат выходных данных
В единственной строке выходного файла выведите одно слово "YES",если вторая перестановка является обратной первой.Иначе выведите "NO".

Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада

становится больше. Определите, через сколько лет вклад составит не менее y рублей. Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

Читайте также

Напишите, пожалуйста, программу на языке Паскаль

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал норму на 10% от предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?

помогите решить пожалуйстаа)

1)Дано целое число ,если оно не четное ,то увеличить его на 3,иначе увеличить его в 5 раз.
2)Даны 2 числа вещественного типа не равные друг другу.Меньшее из них заменить половиной их суммы ,а большее - их удвоенным произведением.
3)Даны 2 числа k и m.Если первое число отрицательно ,то его значение заменить его модулем;иначе второе число заменить единицей .Результат (оба числа) вывести на экран.



Вы находитесь на странице вопроса "Напишите пожалуйста программу на языке Паскаль: Дано число. Если оно кратно 3, то увеличить его на 6, в противном случае обнулить.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.