Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти значение выражения :(a+(d-12)*3)*(c-5*k) где значения переменных a,b.c и k вводится с клавиатуры.

10-11 класс

Annvinny 26 апр. 2014 г., 7:48:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
танчанак
26 апр. 2014 г., 8:29:51 (10 лет назад)

На Паскале:

var a,d,c,k: integer;

begin
writeln('Vvedite znachenie peremennoj a');
readln(a);
writeln('Vvedite znachenie peremennoj d');
readln(d);
writeln('Vvedite znachenie peremennoj c');
readln(c);
writeln('Vvedite znachenie peremennoj k');
readln(k);
res:=(a+(d-12)*3)*(c-5*k);
writeln('(a+(d-12)*3)*(c-5*k)=',res);
readln;
end.




Ответить

Другие вопросы из категории

Распишите до мелочей пожалуйста
Помогите, пожалуйста(Паскаль):

Даны действительные положительные числа x

Читайте также

Ребятки помогите!!!! 1.Написать программу нахождения периметра треугольника .Значение сторон вводятся с клавиатуры. 2. Написать программу

нахождения S прямоугольного треугольника. ЗНАЧЕНИЯ КАТЕТОВ ВВОДЯТСЯ С КЛАВИАТУРЫ!

ПОМОГИТЕ ЗАЙКИ,,,,,

1. Запишите следующее выражение по правилам программирования:



2. Выпишите недопустимые имена переменных:

a) Nomer;
b) S34;
c) И92;
d) Kol_vo54;
e) 45_A;
i) fg-л23

3. Установите соответствие (с помощью стрелок) между переменной и типом данных:

а) A:=3.234 а) Integer
b) Z:=14 b) Real
c) B:=10351 c) Byte
d) K:=-0.2 d) Word
e) C:= 64000

4. Запишите инструкцию:

а) присваивающую переменной V значение 7;

б) увеличивающую значение переменной Z на 30;

в) вычисляющую значение переменной R по формуле (X2+Y2):2;

5. Опишите переменные, необходимые для вычисления:


при x=-5.3, y=7.42

6. Напишите инструкцию вывода на экран:
а) вашего имени б) числа 400 в) значения выражения 7,3(3,22+8,61)

7. Определите, какое значение примет переменная С в результате выполнения данной последовательности операторов присваивания:

a:=8; b:=a/2; c:=43 mod a; a:=(b+c) div 6; b:=b+1; c:=sqrt(abs(a*b-14));

8. Установите соответствие между служебными словами и названиями разделов программы:

а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

9. Найдите ошибки в записях оператора:

a) Write ©;
b) Writeln;
c) Writeln (Введите любое число);
d) Write X,Y;
e) WRITELN (‘воскресенье, нерабочий день’);

10. Какая структура программы верная:

begin
program MyFirst;
X:=Y+195;
end.


program MyProg;
begin
Writeln (‘Привет’);
end.

11. Расположите в правильном порядке строки программы, вычисляющей периметр и площадь параллелограмма:

1) S:=a*h;

6) var a,b,h,p,s: integer;

2) end.

7) readln;

3) program pr;

8) Writeln(‘p=’,p,’ s=’,s);

4) p:=2*(a+b);

9) a:=6;b:=3;h:=4;

5) Uses crt;

10) clrscr;

11) begin

12. Дан текст программы в таблице с ошибками:

исправьте ошибки в программе;что выведется на экран в результате выполнения программы?

Программа с ошибками

Программа без ошибок

На экране будет напечатано:

War: a,b,c – integer, x: real;
Bigin
A=7, b=3,2, c:=a+b;
Writln (summa=, c);
C:=c/2; x:=a-c;
Writeln(‘x=’ , x, ‘kvadrat=’, x*x);
and

13. Перевести блок-схему на язык Паскаль.

Вычисление расстояния между точками А и B.



Найти значение выражения:

1) 25/2= _________ 9) 220 div 10 mod 3 = ________
2) 25 div 2 = ______ 10) 220 mod 10 div 3 = ________
3) 25 mod 2 = ______ 11) -16 mod 11 * 3 = __________
4) 15+21 div 2= ____ 12) 3 div (5+3) = __________
5) 2 div 3 = _______ 13) 3 div 5 + 3 = _________
6) 2 mod 3 = _______ 14) (-19+9) div -5 = ________
7) 11 mod 5 = _____ 15) (16 mod 6) / (2 div 1) = ____
8) 14 mod (5 + 3) = ____ 16) 16 mod 6 / 2 div 1 __________

Задание

№1
Создать
последовательность нажатия клавишей
калькулятора (программу расчёта), найти
значение выражения и записать результат:

23,7 * 3,9 + 71,25 /
2,3 – 78,9*0,8 =
659 – 33,6 *2,7 –
41 / 5,6 – 154 =
12,9 * (4*53,9 –
144) + 77,11 – 56 / 5,5 =
126 + 8,2 * (50,49 /
0,7 – 63) =


Указание:
При выполнении расчётов использовать
ячейку памяти калькулятора:
( М+,
МС, MR,
1/Х
)



Вы находитесь на странице вопроса "Найти значение выражения :(a+(d-12)*3)*(c-5*k) где значения переменных a,b.c и k вводится с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.