Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПОМОГИТЕ ПЛИЗ!!! Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0). Вывести A в степени N: An = A•A•...•A (числа

5-9 класс

A перемножаются N раз).

Polina300802 12 нояб. 2014 г., 11:50:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маруся333123
12 нояб. 2014 г., 14:26:21 (9 лет назад)

function Pow(a:real; n:integer):real;

var

  r:real;

  i:integer;

begin

  r := 1;

  for i := 1 to n do

    r := r * a;

  Pow := r;

end;

 

var

  a:real;

  n:integer;

begin

  write('a = '); readln(a);

  write('n = '); readln(n);

  writeln(a, ' ^ ', n ,' = ', Pow(a, n));

end.

+ 0 -
Lbfyf212
12 нояб. 2014 г., 16:08:24 (9 лет назад)

Program stepen;
Var a: real; b, i, n: integer;
Begin
Readln (a, n);
b:=a;
For i:=2 to n do
a:=a*b;
Writeln(a);
Readln;
End.

Ответить

Другие вопросы из категории

решите пожалуйста срочно надо
Логическая задача: Обманутый продавец

Продавец продает шапку. Стоит она 10 руб. Подходит покупатель, меряет и согласен взять, но у него есть только 25 руб. Продавец отсылает мальчика к соседке разменять эти деньги. Мальчик прибегает и отдает 10+10+5. Продавец отдает шапку и сдачу в 15 руб. Через какое-то время приходит соседка и говорит, что 25 руб. фальшивые, требует отдать ей деньги. Продавец возвращает ей деньги.
На сколько обманули продавца?

Напишите программу на Паскале .

Вычислить сумму всех чисел кратных 3 от 27 до 101 включительно .

Кто изобрёл интернет?

Читайте также

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Помогите решить задачи на цикл с параметром.

Решения оформить как в Паскале.

1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных
2)В фирме работают 5 сотрудников. какую сумму нужно заказать в банке для выплаты им заработной платы, если их зарплата меняется каждый месяц и задаётся бухгалтером с клавиатуры ?
3)Задать 20 чисел.найти среднее произведение чисел, больших 8 и сумму чисел, некратных 15.

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

помогите написать задачу на с++

Хулиганы Первый
и Второй очень не любят доску почёта своей школы. Поэтому они решили наглым
образом украсть оттуда школьную стенгазету, сделанную отличниками, и порвать на
части. Первый хулиган брал кусочек газеты и рвал его на 4 части, а Второй
хулиган – на 7. Однако очень скоро дежурные нашли N кусочков этой
газеты. Им стало интересно, все ли кусочки они нашли. Помогите им.



Вы находитесь на странице вопроса "ПОМОГИТЕ ПЛИЗ!!! Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0). Вывести A в степени N: An = A•A•...•A (числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.