Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В старояпонском календаре был принят двенадцатилетний цикл. Годы внутри цикла носили названия животных: крысы, коровы, тигра, зайца, дракона, змеи,

10-11 класс

лошади, овцы, обезьяны, петуха, собаки и свиньи. Написать программу, которая позволяет ввести номер года и печататет его название по старояпонскому календарю. Справка: 1996 г. - год крысы - начало очередного цикла (остаток от деления равен 4). Help!

КотЭсик 22 нояб. 2016 г., 4:56:12 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karamelka290951
22 нояб. 2016 г., 6:55:32 (7 лет назад)

var

n:integer;

begin

readln(n);

case n mod 12 of

4:writeln('год крысы');

5:writeln('год коровы');

6:writeln('год тигра');

7:writeln('год зайца');

8:writeln('год дракона');

9:writeln('год змеи');

10:writeln('год лошади');

11:writeln('год овцы');

0:writeln('год обезьяны');

1:writeln('год петуха');

2:writeln('год собаки');

3:writeln('год свиньи');

end;

end.

Ответить

Другие вопросы из категории

Объясните, сколько компьютерных терминов спрятано в тексте Мы простые и несовременные люди. С "Плейбоями" и "красотками" не имеем ничего общего.

Лично я книголюб, Айтматова и Аставфьева читающий и почитающий. Ведь до сих пор талантом их никто не превзошел. За минувшие годы перемен произошло видимо-невидимо. Демократия,как говорят, на дворе. Давно уже нет организаций типа МОПР, интернациональные проблемы расстмариваются в ООН и в Совете Европы. Рабочий класс нынче же не гегемон,и торжеств в его честь уже не бывает. Трудовые копейки мы шкатулочке и сбербанку не доверяем, хотя бы потому, что и доверять-то нечего. Любимые мелодии записываются теперь не на виниловом, а на лазерном диске: та же музыка,а звук иначе.

Помогите решить, ребят

Читайте также

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.

Вычислить и напечатать сумму площадей кругов с радиусом от 18 до 99.

Пожалуйста, напишите способом цикл ПОКА или цикл ДЛЯ.

Для приближенного перевода дат с мусульманского календаря на григорианский можно пользоваться следующей формулой: Г = М + 622 - (М/33) где Г - год

григорианского календаря, М - год мусульманского календаря.Какой год был по мусульманскому календарю в 1985 году (год начала изучения информатики в школах России)?
1) 1363-1364; 2) 1405-1406; 3) 2005-2006; 4) 2045-2046.

В рассказе Гарри Киллера "Доллар Джона Джонса" в 1921 году Джон Джонс положил доллар в банк под 3% годовых.Условием вклада было то,что накопившаяся к

соответствующему времени сумма достанется 40-му наследнику Джона Джонса.По сюжету рассказа последнее начисление вклада произошло в 2946 году.Чему был равен вклад Джона Джонса за каждый год?
Нужно решить задачу и и написать программу в Pascal

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3



Вы находитесь на странице вопроса "В старояпонском календаре был принят двенадцатилетний цикл. Годы внутри цикла носили названия животных: крысы, коровы, тигра, зайца, дракона, змеи,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.