Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста составить программу в PascalABC! составте программу, которая заполнит массив а[1..10] случайными целыми числами от 0 до 2 и

5-9 класс

выведит количество элементов, равных 1

Milada 23 февр. 2015 г., 4:19:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
0895426940
23 февр. 2015 г., 7:02:40 (9 лет назад)

var
a:array[1..10] of integer;
k,i:integer;
begin
randomize;
k:=0;

for i:=1 to 10 do begin
  a[i]:=random(2+1);
    if (a[i] = 1) then inc(k);
end;

writeln(k);

end.

P.S. Не забудь отметить лучший ответ! ;-)

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА ПОМОГИТЕ!!! ОЧЕНЬ НАДО!!! ЗАРАНЕЕ СПАСИБО*) Исполнитель "вычеслитель" умеет выполнять только две команды : умножить на 2 и прибавлять

1. Составтьте для вычислителя наиболее короткую программу получения из числа 1 чисел 5, 50 и 99. СКОБКИ ИСПОЛЬЗОВАТЬ НЕЛЬЗЯ!!!

Можете мне помочь написать программу в Pascal, исходя из этой задачи: коробка для подарка обклеивается бумагой, высота, ширина, длина коробки

вводится с клавиатуры, найти площадь необходимой бумаги(площадь куба, видимо) и сумму длин всех рёбер

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Помогите, пожалуйста составить программу в PascalABC! составте программу, которая заполнит массив а[1..10] случайными целыми числами от 0 до 2 и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.