Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу, котораянаходит все углы (в градусах)треугольника со сторонами a, b, c.

10-11 класс

Илюша04 05 янв. 2017 г., 12:42:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nodrihas
05 янв. 2017 г., 14:15:49 (7 лет назад)

        static void Main()
        {
            double a = float.Parse(Console.ReadLine()),
                   b = float.Parse(Console.ReadLine()),
                   c = float.Parse(Console.ReadLine()),
                   al, be, ga;
            if ((a + b <= c) || (a + c <= b) || (c + b <= a))
            {
                Console.WriteLine("No ▲");
            }
            else
            {
                al = (c * c + b * b - a * a) / (2 * c * b);
                be = (a * a + c * c - b * b) / (2 * a * c);
                ga = (a * a + b * b - c * c) / (2 * a * b);
                Console.WriteLine("Alpha: " + Math.Acos(al) * 180 / Math.PI);
                Console.WriteLine("Beta:  " + Math.Acos(be) * 180 / Math.PI);
                Console.WriteLine("Gamma: " + Math.Acos(ga) * 180 / Math.PI);
            }
            Console.ReadKey(false);
        }
Вроде работает...:)

Ответить

Другие вопросы из категории

Даны два массива A(N) и B(N), где N<=15. Найти номер 1-ого нуля массива А и составить массив С(N), где каждый элемент массива С[i]= min(A[i],B[i])

до найденного номера. Вывести на печать номер нуля, массива С и сообщение, если нуль не найден.

написать программу в Паскале.

спасибо

помогите пожалуйста!

напишите по блок-схеме програму. на паскале.

Читайте также

ПОМОГИТЕ! ТОЛЬКО НУЖНО РЕШИТЬ НЕ ЧЕРЕЗ if, A ЧЕРЕЗ CASE1. Пользователь вводит неотрицательное однозначное число A. Написать программу:

вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Написать программу, котораянаходит все углы (в градусах)треугольника со сторонами a, b, c.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.