Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найдите и выведите на экран количество двузначных чисел, у которых сумма цифр равна 13. Либо помогите найти ошибку в моем решении.

5-9 класс

Руфик98128 06 мая 2013 г., 7:13:54 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikasandrosyan
06 мая 2013 г., 9:46:23 (11 лет назад)

готово.........................

+ 0 -
Alinaplaksina2000
06 мая 2013 г., 12:06:54 (11 лет назад)

Ошибка в том, что после цикла не стоят операнды begin-end т.е. он пролетает от 10 до 99 вхолостую.

Ответить

Другие вопросы из категории

помогите плиз срочно!!!

а)в одной многодетной семье у каждого из пяти сыновей было три сестры. сколько всего детей было в семье??
б)у трёх моляров был брат Иван, а у Ивана братьев не было. может ли так быть?

условие: нужно ввести 4 значное целое число и определить является ли оно палиндромом("перевертышем").

Для определения отдельных разрядов числа используется операции div и mod

Что в Паскале обозначает:
program n1;
var
a,b,i,q,l:integer;
constLimit=4
begin
readln(a);
l:=a;b:=0;
while a>0 do
begin
q:=a mod 10;
b:=b*10+q;
a:=a div 10;
end;
if(l=b)then writeln('yes')else writeln('no');
end.
1. while a>0 do
2. q:=a mod 10;
b:=b*10+q;
a:=a div 10;
Я не совсем понимаю, для чего в переменную b мы присвоили значение где b умножено на 10 и к произведению прибавлена q?
3. l:=a;b:=0;
и я не понимаю, почем мы здесь присвоили b значение равное 0?
Объясните пожалуйста!

написать программу в паскале

Читайте также

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

Решите 2 программы. 1) Найдите количество двухзначных чисел, которые делятся на сумму своих цифр. 2) Составьте программу вычисления

количества трехзначных чисел, у которых сумма цифр является чётным числом.

ОЧЕНЬ СРОЧНО!!!



Вы находитесь на странице вопроса "Найдите и выведите на экран количество двузначных чисел, у которых сумма цифр равна 13. Либо помогите найти ошибку в моем решении.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.