Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

5-9 класс

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC

Pskov2005 26 июля 2014 г., 13:08:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dnitry86
26 июля 2014 г., 15:15:14 (9 лет назад)

Program Pr1;
uses crt;
var ch,min,sek,ch2,min2,sek2,a,b,c:integer;
Begin
clrscr;
a:=0;
b:=0;
readln(ch,min,sek,ch2,min2,sek2);
while a<=ch do begin
a:=a+1;
b:=b+3600;
c:=b;
end;
b:=b+min*60+sek;
while a<=ch2 do begin
a:=a+1;
c:=c+3600;
end;
c:=c+min2*60+sek2;
writeln(c-b);
end.

Ответить

Другие вопросы из категории

Помогите решить логическую задачу

Мальчики Никита,Саша и Руслан учатся в разных школах.Они встретились после урока информатики, на котором каждый из них познакомился с одной из операционной системой :Windows,MacOs, и Linux. С какой системой познакомился каждый мальчик если известно что в школе на компьютерах установлены операционные системы: Windows и linux,Саша:Windows и MacOs. Известно что в школе у Руслана одна операционная система с логотипом которой является пингвин.
С объяснением пожайлуста

Читайте также

Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из моментов времени. Известно, что

второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая рассчитывает

количество бактерий на заданное пользователем с клавиатуры целое значение момента времени 15 минут. Мне через Паскаль нужно и еще что бы через операторы white и do.Срочно нужно спасибо заранее.

Помогите срочно решить!

1) Городская метеостанция фиксирует температуру воздуха каждые три часа. В июле колебания температуры были в интервале от 0 до 30. Специальное устройство записывает температуру в двоичном виде с использованием минимально возможного количества бит. Каков информационный объем всех данных, записанных устройством в июле?
2) Текстовый документ, состоящий из 11264 символов, хранился в 8-битной кодировке КОИ-8. Этот документ был преобразован в 16-битную кодировку Unicode. Укажите, какое дополнительное количество Кбайт потребуется для хранения документа? В ответе запишите только число.
3) Дано а=A316, b=3018. Определите число с, записанное в двоичной системе, которое отвечает условию a 4) Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество единиц: 15 14 13 16
5) Производилась двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и 24-битнным разрешением. В результате был получен файл размером 60 Мбайт, сжатие данных не производилось. Какая из приведенных ниже величин наиболее близка к времени, в течение которого проводилась запись?
6) Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, решили использовать неравномерный двоичный код, позволяющий однозначно декодировать двоичную последовательность, появляющуюся на приемной стороне канала связи. Для букв А, Б, В и Г использовали такие кодовые слова: А – 000, Б – 001, В – 010, Г – 011. Укажите, каким кодовым словом может быть закодирована буква Д.
Код должен удовлетворять свойству однозначного декодирования. Если можно использовать более одного кодового слова, укажите кратчайшее из них.

7) Автомат получает на вход четырехзначное десятичное число. По этому числу строится новое число по следующим правилам:
1. Складываются первая и вторая, а также третья и четвертая цифры.
2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
Пример. Исходное число: 5487. Суммы: 5+4=9; 8+7=15. Результат:159.
Определите, какое из предложенных чисел может быть результатом работы автомата.
8)Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи, задавая комбинации точек и тире. Сколько различных символов можно закодировать, используя код Азбуки Морзе длиной не менее двух и не более пяти сигналов (точек и тире)?
9) Десятичное число 59 в некоторой системе счисления записывается как 214. Определите основание системы счисления.
10) при регистрации в компьютерной системе каждому пользователю выдается пароль, состоящий из 11 символов и содержащий только символы И, К, Л, М, Н. Каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит).
Определите объем памяти, отводимой этой программой для записи 20 паролей.

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((

1)Написать программу вычисления модуля разность двух данных целых чисел 2)Составить программу вычесляет в котором n суток, часов, минут,

секунд.

3)Составте программу вычисления площади треугольника с основанием а и высотой h. Значение a и h введите с клавиатуры.



Вы находитесь на странице вопроса "помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.