Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

СРОЧНО ПОМОГИТЕ ПЛЗ Составьте любой массив и из массива выведите только отрицательные числа.ответ отмечу как лучшый помогите на завтра надо

5-9 класс

Grt5gheeee 01 февр. 2015 г., 10:29:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Антоний
01 февр. 2015 г., 12:43:38 (9 лет назад)

ну блин
давай возьмем 10 чисел в вод программы 
к примеру 1 15 228 -10 16 8 10 18 9 10
я все помечу в программе как все делается 
var   
  a : array [1..100] of longint {я поставил массив a одномерным и массив этот в ограничении от 1 до 100, если надо больше просто поставь не 100, а какое хочешь число (если паскаль, максимальное число 9999}
 i,n : longint;

begin
  readln(n) {помечаю n как количество вводимых чисел}
  for i:=1 to n do readln(a[i]); {ввожу числа от 1 до n в столбик из-за окончания ln}
  for i:=1 to n do {пишем массив опять и проверяем введенные числа}
    if a[i]<0 then writeln(a[i]); {проверяем числа с номерами от 1 до n и если число строго меньше 0 то выводим}
end.
все программа готова, ты можешь взять любое число n и взять любые числа, кстати если ничего не найдет, то ничего не выведет

Ответить

Другие вопросы из категории

ДАЮ 25 БАЛЛОВ!!!!!

Работа с Паскалем.
Найти минимальное и максимальное значение из четных чисел и записать их в файл output.txt

Для передачи аварийных сигналов

договорились использовать специальные цветные сигнальные ракеты, запускаемые
последовательно. Одна последовательность ракет – один сигнал; в каком порядке
идут цвета – существенно. Какое количество различных сигналов можно передать
при помощи запуска ровно трёх таких сигнальных ракет, если в запасе имеются
ракеты трёх различных цветов (ракет каждого вида неограниченное количество,
цвет ракет в последовательности может повторяться)?


Петя, Ваня и Саша учатся в одной начальной школе, но в разных классах. Петя перешел в тот класс, в котором в прошлом году учился Саша, а через год Ваня

перейдет в тот класс, который в этом году закончит Петя. В каком классе учится каждый из мальчиков?

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПРОГРАММУ!!!!(в паскале)

Ввести с клавиатуры массив А из 5 элементов, найти минимальное из них

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "СРОЧНО ПОМОГИТЕ ПЛЗ Составьте любой массив и из массива выведите только отрицательные числа.ответ отмечу как лучшый помогите на завтра надо", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.