Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Используя датчик случайных чисел заполнить массив из 20 элементов неповторяющимися числами

10-11 класс

Murat2014 20 сент. 2016 г., 18:31:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анжеио3
20 сент. 2016 г., 20:56:25 (7 лет назад)

Используя Паскаль:

var rndm: array[1..20] of longint;
 i,n1.n2,c : longint;

begin
 for i:=1 to 20 do rndm[i]:=i;
 for i:=1 to 100 do begin
  n1:=random(19)+1;
  n2:=random(19)+1;
  c:=rndm[n1];
  rndm[n1]:=rndm[n2];
  rndm[n2]:=c;
 end;
 for i:=1 to 20 do write (rndm[i],' ');
end.

Ответить

Другие вопросы из категории

Дано натуральное число N и последовательность а1, а2, .....аN натуральных чисел, заданных случайным образом из диапазона [3;100]. Умножить все элементы

этой последовательности, кратные 3, на третий элемент. Решить задачу для N=10 (Написать на Паскале).

72+26в восьмиричной степени
Помогите пожалуйста.

Необходимо написать программу, которая выводит на экран 3 случайных целых числа в диапазоне от 0 до 100. Паскаль АВС.Спасибо заранее

Читайте также

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел



Вы находитесь на странице вопроса "Используя датчик случайных чисел заполнить массив из 20 элементов неповторяющимися числами", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.