Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 970 ответов!

Дана

10-11 класс

строка, состоящая из слов, разделенных пробелами (одним или несколькими).
Вывести строку, содержащую эти же слова, разделенные одним пробелом

Sergeykonar 08 дек. 2016 г., 23:21:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настюня2001
09 дек. 2016 г., 0:09:10 (7 лет назад)

var
  i:integer;
  s,t:string;
  f:boolean;
begin
writeln ('Введите строку');
readln(s);
f:=false;
for i:=1 to length(s) do
  begin
  if (f=false) or (s[i]<>' ') then
    begin
    t:=t+s[i];
    if s[i]=' ' then
      f:=true
      else f:=false;
    end;
  end;
writeln(t);
end.

Ответить

Другие вопросы из категории

Информатика. Нужно прописать каждый шаг решения.

Помогите, пожалуйста, совсем не понимаю, как доказывать истинно ли высказывание.

Умоляю помогите решить!

нужно все семь задании

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Дана", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.