Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

5-9 класс

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

ОтличницаИрка 05 марта 2015 г., 8:59:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Конфетка07809
05 марта 2015 г., 9:35:44 (9 лет назад)

 

var b,i :integer;

a:array[1..10] of integer;

begin

for i:=1 to 10 do

readln(a[i]);

for i:=1 to 10 do begin

if (a[i] mod 5=0) or (a[i] mod 7 =0) or (a[i] div 10=1) or (a[i] mod 10 =1) then b:=b+1;end;

writeln (b);

end.

 

 

var b,c,i :integer

a:array[1..10] of integer;

begin

for i:=1 to 10 do

readln(a[i]);

for i:=1 to 10 do begin

if (a[i] mod 3=0) and (a[i] mod 2 = 0) and (a[i] div 10<>0)and (a[i] div 100=0) then begin b:=b+a[i];c:=c+1;end;end;

writeln(b/c);

end;

Ответить

Другие вопросы из категории

Срочно, решите в паскале!!! ИСПОЛЬЗУЮ ПРОЦЕДУРУ!!!

Дано вещественное а. Не пользуясь никакими арифметическими операциями, кроме умножения , получить:
 а4 за две операции
 а6 за три операции
 а7 за четыре операции
 а8 за три операции
 а9 за четыре операции
 а10 за четыре операции
 а13 за пять операций
 а15 за пять операций
 а21 за шесть операций
 а28 за шесть операций
 а64 за шесть операций



9 задачу решите пожалуйста!!!
Как решить? На, это все мои балы урод!!! 1. Информационное сообщение объемом 1,5 Кбайта содержит 3072 символа. Сколько символов

содержит алфавит, при по­мощи которого было записано это сообщение?

Решение:

2. Для записи текста использовался 256-символьный алфавит. Каждая страница содержит 30 строк по 70 символов в строке. Какой объем информации содержат 5 страниц текста?

Решение:

каково происхождение клинописных значков

Читайте также

Напишите программу, которая в последовательности целых чисел определяет количество трехзначных чисел, кратных 7. Программа получает на вход целые

числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000. Про-грамма должна вывести одно число: количество трехзначных чисел, кратных 7

Программа в Паскале! "Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Отдал все пункты что есть! Помогите!

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.



Вы находитесь на странице вопроса "1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.