Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите заполнить массив из 10 элементов случайными числами от -5 до 5 и произвести сортировку : 1) Методом прямого выбора 2) Методом прямого

10-11 класс

обмена

ZiKzAkS 31 марта 2015 г., 18:44:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikitosan9191
31 марта 2015 г., 21:12:56 (9 лет назад)

const n=5;
var a:array[1..N] of integer;
b:array[1..N] of integer;
m,e,i,min,j,buf,k:integer;
begin
randomize;
e:=-5;
m:=5;
for i:=1 to n do a[i]:=random(M-E+1)+E;

writeln('Sortirovka metodom pryamogo vibora');
for i:=1 to n-1 do begin
min:=i;
for j:=i+1 to n do if a[j]<a[min] then
min:=j;
buf:=a[i];
a[i]:=a[min];
a[min]:=buf;
for k:=1 to n-1 do write(a[k],' ');
writeln(a[N]);
end;

e:=-5;
m:=5;
for i:=1 to n do b[i]:=random(M-E+1)+E;
writeln('Sortirovka metodom pryamogo obmena');
for i:=1 to n-1 do begin
for j:=1 to n-1 do begin
if b[j]>b[j+1] then begin
buf:=b[j];
b[j]:=b[j+1];
b[j+1]:=buf;
end;
end;
for j:=1 to n do write(b[j],' ');
writeln;
end;
end.

 

Выводит ходы сортировки.

 

Ответить

Другие вопросы из категории

Что делает следующая программа? program Whatlslt; var f: file of integer; i: integer; begin reset( f ); while not e

of( f ) do begin read( f, i );

writeln( i );

end;

close(f);

end.

1) выводит в столбик числа, записанные в файле;

2) выводит в строку числа, записанные в файле;

3) записывает числа в новый файл;

4) дописывает числа в существующий файл.

Дано натуральнок K от 1 до 180.Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213...9899. Формат

входных данных Файл содержит число k-позиция искомой цифры. Формат выходных данных Выходной файл содержит искомую цифру. Пример входных и выходных файлов Task1.in Task1.out 4 1 8 3

Найдите минимальное из двух чисел a и b,
Ребятушки,помогите,пожалуйста,очень прошу:*

Текст переводится из КОИ-8 в юникод.Объём этого текста,полученного уже в юникоде,равен 32 бит.Найти N.

Читайте также

Срочно! Помогите! Написать программу в турбо паскале Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить,

есть ли в нем одинаковые соседние элементы.

Пример:

Исходный массив:

4 0 1 2 0 1 3 1 1 0

Заранее огромное спасибо!!!!

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива

Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и найти в нем два максимальных элемента и их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0 максимальные a[4]=10, a[7]=8



Вы находитесь на странице вопроса "Помогите заполнить массив из 10 элементов случайными числами от -5 до 5 и произвести сортировку : 1) Методом прямого выбора 2) Методом прямого", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.