Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Одномерные массивы.

5-9 класс

Дан массив натуральных чисел, состоящий из n элементов. Найти сумму элементов массива, кратных данному числу К.
(паскаль)

Ks8282 26 нояб. 2016 г., 13:00:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexsand2014
26 нояб. 2016 г., 14:47:35 (7 лет назад)

const  n = 10;
var  a :array [1..n] of integer;  k, sum :integer;
begin
  readln(k);  for i:= 1 to n do    readln(a[i]);  sum:= 0;  for i:= 1 to n do    if a[i] mod k = 0 then      sum:= sum +a[i];  writeln(sum);
end.

Ответить

Другие вопросы из категории

племя пульти пользуется 32 символьным алфавитом свод основных законов племени хранится на 512 глинянных табличках, на каждую из которых нанесено ровно 256

символов. какое количество информации содержится на каждом носителе? какое количество информациии заключено во всем своде законов*

Читайте также

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов. Найти сумму элементов массива, кратных данному числу К.

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив

отрицательные элементы начального массива.
с применение подпрограмм и процедур желательно

1.одномерные массивы

Напишите программу на Паскале.ВЫвести на экран номера всех элементов массива B[1..n],не совподающих с максимальным

помогите



Вы находитесь на странице вопроса "Одномерные массивы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.