Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано действительное число х. Вычислите его квадрат , квадратный корень, синус и косинус.

5-9 класс

Turala 20 сент. 2014 г., 11:57:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
добрыйФизрук
20 сент. 2014 г., 14:57:30 (9 лет назад)

var x,a,b,c,d:real;
begin 
writeln('Введите число: '); read(x); 
a:=sqr(x);
writeln ('Квадрат этого числа = ',a);
b:=sqrt(x);
writeln ('Корень квадратный = ',b);
c:=cos(x);
d:=sin(x);
writeln ('Синус = ', c, ' | Косинус = ',d);
end.

Ответить

Читайте также

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

Помогите!СРОЧНО!!! Надо составить программу для Паскаль ABC Дано вещественное число.Если оно

отрицательное, вывести на экран его модуль, а если нет, то вычислить из него квадратный корень.

Дано действительное число а.Вычислите f(a), если

а) f(х)= х2 при -2≤х<2,
4 в противном случае;

б) f(x)= x2+4x+5 при х≤2,
1/х2+4х+5 в противном случае;
пожалуйста..

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Дано действительное число х. Вычислите его квадрат , квадратный корень, синус и косинус.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.