Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано натуральное число. определить какое из цифр в этом числе чаще 0 или 9

10-11 класс

идеот 23 июля 2016 г., 2:30:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sashaspace
23 июля 2016 г., 3:41:45 (7 лет назад)

Var s: string;
    i, z, n, a: integer;
begin
     readln(a);
     s := floattostr(a);
     for i := 1 to length(s) do
     begin
         if (s[i] = '0') then inc(z);
         if (s[i] = '9') then inc(n);
     end;
     writeln(z, ' ', n);
     if (z > n) then writeln('"0" > "9"');
     if (z < n) then writeln('"0" < "9"');
     if ((z = 0) and (n = 0)) then writeln('"0" = "9" = 0!')
        else if (z = n) then writeln('"0" = "9" = ', z);
end.

Только я тут испугался аж: всё правильно, а не так пишет х) Если ввести число, начинающееся с нуля, то первые нули отбросятся:)

Ответить

Другие вопросы из категории

СРОЧНО!!! ПОЖАЛУЙСТА!!!!

Напишите программу: Вычислите сумму чётных натуральных чисел от 1 до n.

Ответить на вопросы: 1. Определите тип массива описанный в программе. 2.определите какие блоки программы присутствуют в тексте. 3.Определите

размер массива. 4. Сколько элементов массива обрабатывается.

For i:= 0 to 10 do

A [ i] := i ;

for i := 0 to 10 do

begin

k := A [i];

A [i] : = A[10-i];

k := A[10-i];

end;

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

напишите в паскале пжл

Дано натуральное число. Определить какое из цифр встречается в этом числе чаще 0 или 9

Автомат получает на вход четырехзначное десятичное число, в котором все цифры четные. По этому числу строится новое число по следующим правилам.

1. Складываются 1я и 2я, а также 3я и 4я цифры.
2. Полученные два числа записываются друг за другом в порядке убывания(без разделителей).

Определите, какое из перечисленных ниже чисел может быть результатом работы автомата.
1) 68
2) 87
3) 816
4) 186
Объясните почему) Заранее спасибо!

Автомат получает на вход 3х значное 10тичное число. По этому числу строится новое, по следующим правилам. 1) Перемножаются 1 и 2, а также 2 и 3я

цифры числа.

2) Полученные 2 числа записываются друг с другом в порядке возрастания (баз разделителей)

Определите, какое из чисел может быть результатом работы автомата.

1)197 2)1218 3)186 4)777

Поиск результатов по фразе "A 5. Автомат получает на вход четырёхзначное восьмеричное число. По этому числу строится новое число по следующим правилам. 1.

Складываются первая и вторая, а также третья и четвёртая цифры. 2. Полученные два числа в восьмеричной системе счисления записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходное число: 4531. Суммы: 4+5 = 9; 3+1 = 4. Результат: 411. Определите, какое из следующих чисел может быть результатом работы автомата. 1) 117 2) 1213 3) 1511 4) 1517
Здравствуйте.
Необходим ход решение задачи, подробный



Вы находитесь на странице вопроса "дано натуральное число. определить какое из цифр в этом числе чаще 0 или 9", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.