Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано натурального число.Определить произведение его цифр.

5-9 класс

Dibaal 24 дек. 2013 г., 22:55:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Miglow
25 дек. 2013 г., 1:44:00 (10 лет назад)

uses crt;
var x,y,z:integer;
begin
     readln(x);
     y:=1;
     while x>0 do
     begin
          z:=x mod 10;
          y:=y*z;
          x:=x div 10;
     end;
     writeln(y);
end.

Ответить

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "Дано натурального число.Определить произведение его цифр.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.