Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

10-11 класс

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Evgeny25565 12 марта 2015 г., 0:46:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ke293ксюха
12 марта 2015 г., 3:41:09 (9 лет назад)

{12. Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце.}

+ 0 -
Tenuma
12 марта 2015 г., 6:31:21 (9 лет назад)

Program asd;
USES crt;
Const n=3;
Const m=3;
Var A,B:array [1..n, 1..m] of integer; 
k,s,i,j,q:integer;
BEGIN
Clrscr;
For i:=1 to n do 
begin 
for j:=1 to m do 
 begin   
A[i,j]:=random(9);   
write(' ',A[i,j]:2); 
  end;   
  Writeln; 
   end; 
For i:=1 to n do 
 begin   
for j:=1 to m do 
  begin   
 If i=j then S:=S+A[i,i]; 
  end;   
end;   
Writeln('Matriza A: ',s); 
For i:=1 to n do 
begin   
for j:=1 to m do   
 begin   
 B[i,j]:=random(9); 
  Write(' ',B[i,j]:2); 
  end;

Ответить

Другие вопросы из категории

Задание самого высокого уровня сложности. (Новичкам не беспокоить!)

Нужно написать программу, при помощи которой можно будет преобразовать из шестнадцатеричного кода в десятеричную (Желательно на Delfi!)

ответьте на вопрос пожалуйста
НА ПАСКАЛЕ С УКАЗАТЕЛЯМИ!

Ввести с пульта оператора в массив А(10) любые целочисленные числа.Программно записать в обратном порядке.Результат вывести на экран

Глаза - органы слуха.

у человека два уха.
Пингвины живут в Африке.
угрюмое небо.
Электронное устройство.
Компьютер- электронное устройство

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20].

Найти номер первого отрицательного элемента, делящегося на 5 с остатком 2.напишите пожалуйста программу в лазарусе

Найти сумму и количество элементов в каждом столбце матрицы, являющихся простыми числами.

Если можно, то с объяснениями, пожалуйста. Заранее благодарна!

Программирование.Паскаль.Массивы

1)Дан массив Р(15).Найти сумму всех отрицательных элементов с четными индексами.Полученный результат вывести на экран.

2)Ввести с пульта оператора массив МАС1 семь целых чисел. Переписать из МАС1 в МАС2 элементы значения которых положительные,в МАС3 элементы значения которых отрицательные. На пульт оператора вывести значения МАС1,МАС2,МАС3



Вы находитесь на странице вопроса "Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.