Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано 3-х значное число. Определить образуют ли цифры упорядоченную последовательность.

10-11 класс

Alinaturshatov 06 дек. 2013 г., 22:47:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Seyrangrigorya
07 дек. 2013 г., 1:46:17 (10 лет назад)

var
  n, m, d: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  if (n < 100) or (n > 999) then
    Writeln('У Вас странное представление о трехзначных числах!')
  else begin
    d := n div 100; {старшая}
    n := n mod 100;
    m := n div 10; {средняя}
    n := n mod 10; {младшая}
    if (m > d) and (n > m) then
      Writeln('Цифры следуют в возрастающей последовательности')
    else if (m < d) and (n < m) then
      Writeln('Цифры следуют в убывающей последовательности')
    else Writeln('Цифры не образуют монотонную последовательность')
  end
end.

Тестовое решение:

Введите трехзначное число: 159
Цифры следуют в возрастающей последовательности


+ 0 -
Fizikary
07 дек. 2013 г., 4:12:23 (10 лет назад)

Язык программирования?

+ 0 -
алинёнок3456
07 дек. 2013 г., 5:30:30 (10 лет назад)

Паскаль

Ответить

Другие вопросы из категории

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

СРОЧНО ПЛИЗ !!!!(¬A¬B¬C)v(¬A¬BC)v(¬AB¬C)v(A¬B¬C)

Помогите упростить ... только поэтапно, законы не надо объяснять просто поэтапное упрощение ... "Ответы появятся здесь в ближайшее время" ндааа...

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)



Вы находитесь на странице вопроса "Дано 3-х значное число. Определить образуют ли цифры упорядоченную последовательность.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.