Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, плиз, очень срочно!!! Составить алгоритм, написать программу, которая заполняет массив из 20 данных случайными числами и делят его на

10-11 класс

два массива, в один помещает четные числа в другой нечетные. Вывести исходный массив, массив четных чисел и нечетных чисел.

Спасибо!

Відьма 08 марта 2017 г., 6:55:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Matyushin97
08 марта 2017 г., 8:21:54 (7 лет назад)

var

  a,b,c:array [1..20] of integer;

  i,k,l:integer;

begin

  randomize;

  k:=1;

  l:=1; 

  writeln ('Исходный массив: '); 

  for i:=1 to 20 do

   begin

    a[i]:=random(9)+1;

    if a[i] mod 2 = 0 then

     begin

      b[k]:=a[i];

      inc(k);

     end else

      begin

       c[l]:=a[i];

       inc(l);

      end; 

    write (a[i],' ');

  end;

  k:=k-1;

  l:=l-1; 

  writeln;

  writeln ('Массив четных чисел');

  for i:=1 to k do write (b[i],' ');

  writeln;

  writeln ('Массив нечетных чисел');

  for i:=1 to l do write (c[i],' ');

  writeln;

  readln;

end.

Ответить

Другие вопросы из категории

1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234)

2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата. Например, 6*6 = 36 , 5*5 =25, 76*76=5776. Определить, является ли данное число автоморфным.

Помогите пожалуйста с паскалем.

Составить блок схему. Составить программу на языке паскаль.
Дан массив в котором все элементы различны. Удалить из него минимальный элемент.

Помогите решить информатику.

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Срочно! Помогите! Написать программу в турбо паскале Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить,

есть ли в нем одинаковые соседние элементы.

Пример:

Исходный массив:

4 0 1 2 0 1 3 1 1 0

Заранее огромное спасибо!!!!

Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

составьте программу ,которая заполняет массив а[1..8] случайными целыми числами в диапазоне от 1 до 10 ,затем изменяет знак элементов с четными индексами

на противоположный.
выведите на экран исходный и полученный массивы
очень прошу



Вы находитесь на странице вопроса "Помогите, плиз, очень срочно!!! Составить алгоритм, написать программу, которая заполняет массив из 20 данных случайными числами и делят его на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.