Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Помогите пожалуйста я вас очень прошу ,не могу сделать задание по информатике 6 класс

5-9 класс

Стася9999 09 авг. 2013 г., 18:30:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dvoechik
09 авг. 2013 г., 20:20:46 (10 лет назад)

                            Исходные данные           Промежуточные данные          Результат

                                      X     -     Y                               X    -   Y                                          X    

                                                                                                                                            5

                                      5-25

                                      5-15

                                      5-10

                                      5-5

 

                                                                                                                                            1

                                      9-14 

                                      9-5

                                      4-5

                                      4-1

                                      3-1

                                      2-1

                                      1-1

 

                                                                                                                                            6

                                     12-90

                                    12-78

                                     12-66

                                     12-54

                                     12-42

                                     12-30

                                     12-18

                                     12-6

                                      6-6

 

 

 

 

Мы так в классе с учительнице решали!!!))))

+ 0 -
Dareka2000
09 авг. 2013 г., 23:11:44 (10 лет назад)

что не опнятно именно? как работает блок-схема?

если в блок-схеме дело, то объясню. Это цикл While(пока). Пишу блок-схему на русском.

Начало

Ввод х, у

Пока х=у, если да то вывод Х и уход на конец.

если нет, идёт дальше условный оператор if(если).

Если x>y если да, то ячейке х присвой значение х-у, если нет, то ячейке у присвой значение у-х. Дальше программа уходит на повтор.

Объясню на примере чисел.

вводим данные х=10, у=15;

10 не равно 15, значит идём на условный оператор if 

10 < 15, ячейке У присваиваем значение 15-10

на экране 5.

на всякий могу написать программу.

Program af;

uses crt;

var x,y:integer;

begin

clrscr;

     readln(x,y;

     while x=y do begin

                                    if x>y then x:=x-y

                                     else Y:=Y-X;

       end;

writeln(x);

readln;

end.

                                                                      

                                    

 

Ответить

Другие вопросы из категории

Для каждого из приведенных объектов укажите величину и значение:

ОБЪЕКТ СВОЙСТВО
Человек Рыжеволосый
Арбуз Семикилограммовый
Чашка. Фарфоровая
Автомобиль Японский
Жесткий диск. Большой
Монитор. Семнадцатидюймовый

помогите пожалуйста 6 и 7

Читайте также

Задача по програмированию. По этому графику нужно определить и вывести на экран попадёт ли точка в закрашенный промежуток или нет.

Помогите пожалуйста, тему пропутила и никак не могу понять как сделать.

Здравствуйте! Помогите пожалуйста, весь интернет облазила, не могу найти ответ на свой вопрос, вся надежда на этот сайт!

Задали сделать презентацию о Белке и Стрелке. Я работаю в "Презентация Microsoft PowerPoint" (в других не понимаю как, мне кажется эта наиболее удобная) и мне надо подобрать космический фон. Там, в "Дизайне" этой презентации ничего подобного нет. Я нашла в интернете подходящую картинку для фона, скачала ее на компьютер но я не знаю как ее вставить. Там есть "Шаблоны оформления на Microsoft Ofice Online", но там я ничего не поняла (написала "Космос", вышли несколько картинок, загрузила одну и теперь она неизвестно где) и есть "Шаблоны оформления: Дополнительные", там он просит найти фото. Я точно знаю куда я его загрузила. проверяю несколько раз, но он не находит. Помогите пожалуйста, 3 дня ответ не могу нигде найти!!!



Вы находитесь на странице вопроса "Помогите пожалуйста я вас очень прошу ,не могу сделать задание по информатике 6 класс", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.