Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

дан одновременный массив из п целых положительных чисел.составить программу вычисления их среднего гармоничного

10-11 класс

Candywassa 10 сент. 2013 г., 16:52:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iluha1999
10 сент. 2013 г., 19:19:05 (10 лет назад)

var

  a : array [1..100] of integer;

  n, i : integer;

  sum : real;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  sum := 0;

  for i := 1 to n do sum := sum + 1 / a[i];

  sum := n / sum;

  writeln (sum);

end.

Ответить

Другие вопросы из категории

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "дан одновременный массив из п целых положительных чисел.составить программу вычисления их среднего гармоничного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.