Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Профессор Самоделкин решил изготовить объемную модель кубиков из спичек, используя спички для рёбер кубиков. Длина ребра каждого кубика равна одной спичке

5-9 класс

. Для построения модели трех кубиков он использовал 28 спичек. Какое наименьшее количество спичек нужно Самоделкину для построения модели из N кубиков? Все числа в задаче не превышают 2·109.

Нюша19 04 авг. 2014 г., 2:39:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PolinaSolovyova
04 авг. 2014 г., 3:35:26 (9 лет назад)

если делать, как Самоделкин, стыковать кубики столбиком,

то получится так:

var

n:integer;

begin

readln(n);

writeln(4*(2*n+1),' спичек понадобится');

end.

 

а если находить именно наименьшее число спичек, то надо рассматривать случаи, когда кубики складываются в квадраты и кубы соответственно, но это слишком сложно.

 

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО!)
В текстовом редакторе имеется текст, состоящий из трех абзацев: Абзац 1 Абзац 2 Абзац 3 Учитель предложил ученику выполнить

следующий алгоритм:

1. Выделить первый абзац.

2. Выполнить команду Правка → Копировать.

3. Установить курсор в начало второго абзаца.

4. Выполнить команду Правка → Вставить.

5. Нажать клавишу Enter.

6. Выделить третий абзац.

7. Выполнить команду Правка→Удалить

Читайте также

1. Даны числа от 5 до 16. Необходимо вывести на экран (в столбик) удвоенное значение каждого числа.

Пример вывода ответа: 5*2 = 10
6*2 = 12 и т.д.
2) Напишите программу перевода расстояния из метром в сантиметры для значений длин от 1 до 15 метров.

(Информатика. 8 класс. Паскаль)

Помогите срочно решить!

1) Городская метеостанция фиксирует температуру воздуха каждые три часа. В июле колебания температуры были в интервале от 0 до 30. Специальное устройство записывает температуру в двоичном виде с использованием минимально возможного количества бит. Каков информационный объем всех данных, записанных устройством в июле?
2) Текстовый документ, состоящий из 11264 символов, хранился в 8-битной кодировке КОИ-8. Этот документ был преобразован в 16-битную кодировку Unicode. Укажите, какое дополнительное количество Кбайт потребуется для хранения документа? В ответе запишите только число.
3) Дано а=A316, b=3018. Определите число с, записанное в двоичной системе, которое отвечает условию a 4) Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество единиц: 15 14 13 16
5) Производилась двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и 24-битнным разрешением. В результате был получен файл размером 60 Мбайт, сжатие данных не производилось. Какая из приведенных ниже величин наиболее близка к времени, в течение которого проводилась запись?
6) Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, решили использовать неравномерный двоичный код, позволяющий однозначно декодировать двоичную последовательность, появляющуюся на приемной стороне канала связи. Для букв А, Б, В и Г использовали такие кодовые слова: А – 000, Б – 001, В – 010, Г – 011. Укажите, каким кодовым словом может быть закодирована буква Д.
Код должен удовлетворять свойству однозначного декодирования. Если можно использовать более одного кодового слова, укажите кратчайшее из них.

7) Автомат получает на вход четырехзначное десятичное число. По этому числу строится новое число по следующим правилам:
1. Складываются первая и вторая, а также третья и четвертая цифры.
2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
Пример. Исходное число: 5487. Суммы: 5+4=9; 8+7=15. Результат:159.
Определите, какое из предложенных чисел может быть результатом работы автомата.
8)Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи, задавая комбинации точек и тире. Сколько различных символов можно закодировать, используя код Азбуки Морзе длиной не менее двух и не более пяти сигналов (точек и тире)?
9) Десятичное число 59 в некоторой системе счисления записывается как 214. Определите основание системы счисления.
10) при регистрации в компьютерной системе каждому пользователю выдается пароль, состоящий из 11 символов и содержащий только символы И, К, Л, М, Н. Каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит).
Определите объем памяти, отводимой этой программой для записи 20 паролей.

120 БАЛЛОВ!!!

Решить задачу с помощью схемы:

Увлечения.

Витя, Саша, Андрей и Толя собирали модели
самолетов. Двое делали модели из белой пластмассы, а двое – из серой. Саша и Андрей,
Саша и Толя делали модели из пластмассы разного цвета. Получились три модели
самолетов «Ту» и одна – «Су».

Какую модель и из какого
материала делал каждый из мальчиков, если Саша делал модель самолета «Су» из
белой пластмассы

1) как объединить операторы в блок для выполнения в цикле 2)привидите пример одного из цикла 3)

решите задачу через While:

прибавьте данное число к четным индексам и вычтите его же из нечетных.. спасиб заранее

решите задачу: сколько дискет обьёмом 1,44 мб необходимо для хранения энциклопедии из 60 томов по 500 страниц на каждой из которой по две

полосы,содержащей 80 строк из 45 знаков?,только обязательно с дано,формулой которую подставили,и решение.



Вы находитесь на странице вопроса "Профессор Самоделкин решил изготовить объемную модель кубиков из спичек, используя спички для рёбер кубиков. Длина ребра каждого кубика равна одной спичке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.