Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Помогите плииз..

5-9 класс

Написать программу которая выводит на экран все подмножества множества:{1,2,3,4}

ЗаЙкА004567 02 янв. 2014 г., 4:38:02 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andreyronix
02 янв. 2014 г., 7:00:01 (10 лет назад)

var    
 a,b,c,d : integer;  
Begin  
   for a:=1 to 4 do    
    for b:=a+1 to 4 do        
     for c:=b+1 to 4 do    
      for d:=c+1 to 4 do        
       writeln(a:3,b:3,c:3,d:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        for c:=b+1 to 4 do
          writeln(a:3,b:3,c:3);
     for a:=1 to 4 do
       for b:=a+1 to 4 do
        writeln(a:3,b:3);
     for a:=1 to 4 do
       writeln(a:3);
    readln;
   End.

Ответить



Вы находитесь на странице вопроса "Помогите плииз..", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.