Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решите задачу : дан массив из N целых элементов. замените четные элементы массива на число 10

5-9 класс

Bade1 15 янв. 2015 г., 0:06:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LeraCOOL1
15 янв. 2015 г., 2:20:45 (9 лет назад)

uses crt;
const N=10;
var a:array[1..N] of integer;
    x:integer;
begin
     for x:=1 to N do
     begin
          write('a[',x,']:');
          readln(a[x]);
          if a[x] mod 2=0 then a[x]:=10;
     end;
     writeln;
     for x:=1 to N do
         writeln('a[',x,']:',a[x]);
end.

+ 0 -
Angelikatrit
15 янв. 2015 г., 5:07:17 (9 лет назад)

var
a:array[1..9999] of integer;
n,i:integer;
begin
readln(n);
for i:=1 to n do
begin
readln(a[i]);
if a[i] mad 2 = 0 then a[i]:=10;
end;
for i:=1 to n do
write(a[i],' ');
end.

Ответить

Другие вопросы из категории

как посмотреть историю
1. напишите программу которая вводит значения 3 переменных a и b с приглашениями к ввожу каждой переменной и выводит их разность. Приглашение и ввод

каждого значения произвести в отдельных строках. Ввод сопроводить пояснениями.

2. Нипишите программу ввода значений A,B,C в одной строке и выведите результат выражения A*(B/3,14)+(C*3) в отдельной строке.

3. написать программу

а:=5; b:=6

найти: сумму, разность, частное и произведение

На полке стояли 25 волшебных книг по заклинаниям, все они были прочитаны Гермионой, Гарри Поттером или Роном. При этом не было ни одной книги, которую бы

прочитали все. 4 книги прочитали и Гарри Поттер, и Рон. Гермиона прочитала 7 книг, которых не читали ни Гарри Поттер, ни Рон, и две книги, которые читал Гарри Поттер. Всего Гарри Поттер прочитал 11 книг. Сколько прочитал только Рон?

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Кто решит задачу?

Дан массив из N целых чисел. Написать программу, определяющую, есть ли в массиве два соседних положительных элемента. Если есть, то вывести индекс первого элемента, входящего в первую пару.



Вы находитесь на странице вопроса "Решите задачу : дан массив из N целых элементов. замените четные элементы массива на число 10", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.