Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Составить программу для нахождения корней квадратного уравнения 1,5х² - 21,5х + 8=0

10-11 класс

Dzhieriebtsov 27 нояб. 2013 г., 20:30:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dariandro
27 нояб. 2013 г., 21:41:08 (10 лет назад)

var a,b,c,d,x1,x2:real;
begin
a:=1.5;
b:=-21.5;
c:=8;
d:=sqr(b)-4*a*c;
if d>0 then
begin
x1:=((-1)*b+sqrt(d))/(2*a);
x2:=((-1)*b-sqrt(d))/(2*a);
writeln('x1=',x1,' x2=',x2);
end
else if d=0 then
begin
x1:= ((-1)*b)/(2*a);
writeln('x=',x1);
end
else writeln('Корней нет');
end.

Ответить

Другие вопросы из категории

Люди добрые помогите пожалуйста(сделайте подробно)

1.Какое количество информации получит игрок, которому из колоды в 32 карты
достают короля пик? А если то же, но из колоды в 36 карт?
2. В рулетке общее количество лунок 128. Какое количество информации мы получаем, увидев, что шарик остановился в 25 черное?
3.Сколько страниц в брошюре, если сообщение о том, что случайно открылась 17 страница содержит 6 бит информации?
4. Сколько нужно задать вопросов, чтобы угадать натуральное число не более 100?

Програмирование!!!, помогите)

Написать программы для выполнения следующих заданий:
Бесконечно печатать букву А: ААААААААААА.....
Ответ:
3. Задание
Бесконечно печатать 1000 999 998 997 996......


Заданы 2 значения натурального числа N(0<=N<=100000000), записанные в десятичной системе счисления с неизвестным основанием A(2<=A<=16).

Написать программу на, которая определяет неизвестное основание системы счисления.



Вы находитесь на странице вопроса "Составить программу для нахождения корней квадратного уравнения 1,5х² - 21,5х + 8=0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.