Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Срочно!!!!

10-11 класс

ввести натуральное число и определить, верно ли, что сумма цифр равна 10

Ekaterinkatr98 13 мая 2014 г., 5:17:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лалалэй
13 мая 2014 г., 7:41:33 (9 лет назад)

Pascal:
var n,sum:integer;
begin
  sum:=0;
  write ('N = ');
  readln (n);
  while n <> 0 do
   begin
    sum:=sum+(n mod 10);
    n:=n div 10;
   end;
  if sum = 10 then writeln ('YES') else writeln ('NO');
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n,sum = 0;
  cout <<"N = ";
  cin >>n;
  while (n!=0)
  {
   sum+=n%10;
   n/=10;
  }
  if (sum==10)
    cout <<"YES" <<endl;
  else cout <<"NO" <<endl;
  return 0;
}

Ответить

Читайте также

Помогите срочно!!

Даю 20 баллов

помогите пожалуйста написать программу!!!СРОЧНО!!!

в одномерном массиве все отрицательные элементы заменить модулем, а положительные заменить числом 888



Вы находитесь на странице вопроса "Срочно!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.