Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

программирование циклов :

10-11 класс

Составьте программу по которой компьютер десять раз запросит ввод целых чисел и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных
помогите пожалуйста очень прошу )

Lena199512 04 марта 2014 г., 21:21:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
закон
05 марта 2014 г., 0:00:21 (10 лет назад)

#include <iostream>
int main()
{
  int c;
  int n = 0;  
  for (int i = 0; i < 10; i++){
    std::cin >> c;
    if (c % 2) n++;
  }
  std::cout << 10-n << "  HE:" << n;
  
  return 0;
}

+ 0 -
Pirtazzz
05 марта 2014 г., 0:32:14 (10 лет назад)

Названия переменных переведите в поисковике если не догадываетесь и запомните)
var even,odd,value:integer;
begin 
for var j:=1 to 10 do   
begin     
write('Write number:');     
 read(value);     
 value:= value mod 2;     
case value of        
0:inc(even);       
1:inc(odd);     
end; 
end;     
 writeln('Even = ',even);   
writeln('Odd =',odd);
end.

Ответить

Другие вопросы из категории

Помогите решить задачу в паскале.

Даны три массива:
A = {17.2, 9.3, 14.5, -11.7, 4.3,
5.9, -11.9, 12.3, -14.1, -15.3},

Читайте также

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Найти сумму произведений a и b. a, b вводятся в цикле их 4 пары. Блок-схема.

Объясните пожалуйста еще цикл for to do и счетчик, для чего он служит.

Составление таблицы функции y=a³/(a²+x2) для x , принадлежащих отрезку [-1;1] с шагом 0.1. Так как пример цикла типа for должен быть целочисленным ,

удобнее использовать цикл while, в котором значение x можно изменять при каждом шаге на Dx=0.1



Вы находитесь на странице вопроса "программирование циклов :", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.