Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Дан фрагмент алгоритма для вычисления:

5-9 класс

а:= 7
b:= 16
если (а - b >/= а)
то с:= b + 2 * a
иначе с:= b - 2 * a
с:= 10 + с/2
Выполните предложенный фрагмент алгоритма. Какое значение будет иметь переменная "с" после выполнения этого фрагмента?

молонко 15 марта 2014 г., 20:42:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Luda160775
15 марта 2014 г., 23:31:51 (10 лет назад)

Добрый вечер!
Вот полный код программы на Pascal:

Var a,b: integer;
c: real;
Begin
a := 7;
b := 16;
If ((a-b) >=a) then c := b+2*a
else c := b-2*a;
c := 10+c/2;
Writeln (c);
End.
При выполнении этой программы получаем ответ 11.
Т.к. a-b=-9, то выполняется выражения после ELSE. Получаем с = 16 - 2 * 7 = 2. Далее с = 10 + 2 / 2 = 10 + 1 = 11.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА ОТВЕТЫ!!!!

Дано: x=1F416 , y=7018
. Какое из чисел Z, записанных в двоичной системе
счисления, удовлетворяет неравенству y 1) 1111110012 2) 1111001112 3) 1101111002 4) 1101101112

Дано: a=101101112
, b=A616 . Какое из чисел С, записанных в двоичной системе
счисления, удовлетворяет неравенству b 1) 101110102 2) 101010102 3) 1010101002 4) 101000102


Дано: a=111001102
, b=2718
. Какое из чисел С, записанных в шестнадцатеричной
системе счисления, удовлетворяет неравенству a>C>b ?
1) AA16 2) B816 3) D616 4) F016


Исполнитель Русский повар умеет выполнять следующие команды: ВЗЯТЬ Х ПОДЖАРИТЬ Х ПРОВЕРНУТЬ Х В МЯСОРУБКЕ ЗАКАТАТЬ Х В У СВАРИТЬ Х НАРЕЗАТЬ Х ПОЛОЖИТЬ

Х НА У Вместо букв Х и У можно подставлять слова МЯСО ТЕСТО СЫР ХЛЕБ ТО ЧТО ПОЛУЧИЛОСЬ. Используя данные команды составьте алгоритм двух любых съедобных блюд. названия блюд подпишите. БЛЮДО № 1: БЛЮДО № 2:

Читайте также

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

1) Сколько данных необходимо ввести для вычисления площади квадрата? 2) Определите результат работы программы : writeln ('15+15=',15+15).

3) Какая фигура в блок-схеме предназначена для выводы данных?

4) Определите результат работы программы : a:=-6 b:=-5 a:=a-2*b;b"=a

5) Скольких команд ввода исходных данных достаточно для решения квадратного уравнения?

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)



Вы находитесь на странице вопроса "Дан фрагмент алгоритма для вычисления:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.