Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Напишите программу, определющую что введенная строка- число или нет.(turbo pascal)

10-11 класс

Vikaa252 17 июля 2014 г., 9:59:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dkrasnova99
17 июля 2014 г., 12:56:48 (9 лет назад)

s:string;
i, k:integer;
begin
readln(s);
for i:=1 to length(s) do
if (odr('s[i]')>47) and (ord('s[i]')<58) then k:=k+1;
if k=length(s) then writeln('число')
else writeln('нет');
readln;
end. 

Ответить

Другие вопросы из категории

помогите пожалуйста очень прошу
перевести из двоичной системы в десятиричную :

10110011,01
1010111111,011
110110101,11
11111010,111

все задание, срочно надо

Читайте также

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Напишите программу, определющую что введенная строка- число или нет.(turbo pascal)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.