Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите пожалуйста!!!задание по информатике(паскаль)

5-9 класс

Составить программу описания двух переменных чисел:трех действительн., трех целых, трех постоянных ,целые(2 чиловые ,1 символьная)
на уроке успели только 1 пример сделать:
Program _ Zadacha _1 ;
const_ s1=3
pi=3.14;
var_c2,c1:integer;
b2:real;
begin
end.

Ksa909909 28 апр. 2014 г., 3:05:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Arinasusorova1231
28 апр. 2014 г., 4:11:22 (9 лет назад)

Начнем сначала. Паскаль является строго типизированным языком, значит чтобы использовать переменную, надо её сначала добавить в специальный блок var. 

Константы добавляются отдельно. 

Рассмотрим сперва неольшой пример, не имеющий отношение к твоей задаче:

program task1;

var i:integer;

begin

write("Vvedite i: ");

readln(i);

writeln(i);

end.

Программа просто попросит ввести i, запомнит введенное значение в ячейку с именем i.

Так вот чтобы разрешить использовать ячейку с именем i, мы и должны добавить её var i:integer; (ячейка i в которую можно класть целые числа, integer - целое по английски)

 

Теперь по твоему заданию:

1. в Паскале нет "переменных" чисел,

вот типы, которые есть в Паскале:

 

для целых чисел:
integer, диапазон -32768..32767
byte, диапазон 0..255
word, диапазон 0..65535
shortint, диапазон -128..127
longint, диапазон -2147483648..2147483647

 

для вещественных типов (в такие ячейки можно класть как целые числа, так и числа с точкой)

single (мало значащих цифр)

real (средне значащих цифр)
double (много значащих цифр)
extended (очень много значащих цифр)


логический тип
boolean может быть либо true либо false


Символьный тип
char просто любой символ, из поддерживаемых Паскалем (ASCII кодировка)

 

Таким образом фраза 

"Составить программу описания двух переменных чисел" понята мной как:

Ответить

Другие вопросы из категории

Запишите

на языке Паскаль программу, которая вычисляет сумму кодов букв в слове БАЙТ.

Дано целое число N и набор из N целых чисел. Найти минимальное положительное число из данного набора. Если положительные числа в наборе отсутсвуют, то

вывести 0.
С выводом минимального положительного числа у меня вроде бы получилось, а вот с проверкой на отрицательность не вышло

Напишите пожалуйста б) и в) как их записать в ячейке Microsoft Excel.

Вычислите значение логических выражений. То что написано А - истина B - ложь это не правильно, это зачеркнуто(не обращайте внимание)

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов. Найти сумму элементов массива, кратных данному числу К.

Читайте также

Задание по информатике!!!

Помогите пожалуйста
Компьютерный вирус А заполняет 2 Гбайта за один месяц, вирус В заполняет 2 Гбайта за два месяца, вирус С заполняет 2 Гбайта за три месяца, вирус D заполняет 2 Гбайта за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Сколько Гбайтов они заполняют за один месяц?

Помогите с заданием по информатике:

Превратите одно слово в другое,всякий раз заменяя по одной буве так,чтобы новое слово было существительным в именительном падеже.
а)ночь-...-...-...-...=день
б)рота-...-...-...-...=полк
в)бант-...-...-...-...=коса
г)бег-...-...-...-...-...=шаг
д)море-...-...-...-...-...-...=суша
е)миг-...-...-...-...-...-...-...=век

помогите решить задание по информатике

задание на картинке

помогите пожалуйста задача по информатике if8 паскаль

даны два числа.Вывести в начале большее а затем меньшее.



Вы находитесь на странице вопроса "помогите пожалуйста!!!задание по информатике(паскаль)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.