Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Массивы.

5-9 класс

Массив из 10 элементов заполнен случайными числами. Узнать кол-во элементов массива >10 <70.

Romzezik 23 июля 2014 г., 16:19:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
юлиячир
23 июля 2014 г., 18:32:22 (9 лет назад)

Uses Crt;
var
i:integer;
a:array[1..10] of integer;
count: integer;
Begin
ClrScr;
randomize;
count:=0;
for i:=1 to 10 do begin 
a[i]:=random(200)-100;
if (a[i]<10) or (a[i]>70) then
count:=count+1;
write(a[i],' ');
end;
writeln;
writeln(count);
End.

Ответить

Другие вопросы из категории

1.Для кого будет информативно следующее сообщение? Программа - это алгоритм, записанный на языке программирования. 1)для дворика 2)для программиста

3)для парикмахера 4)для ученика 3 класса. С помощью каких программ выполняется большинство операций по обслуживанию безопасности компьютера? 1)архиваторов 2)нтивирусных программ 3)файловых менеджеров 4)утилит помогите пожалуйста!

Читайте также

В одно мерном массиве А(10) найти количество положительных и отрицательных элементов

Программа сделана правильно,но как только ее хочешь запустить там пишет "введите длину массива"какое число нужно вводить?

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.



Вы находитесь на странице вопроса "Массивы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.