Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Cоставить алгоритм и написать программу.

10-11 класс

Найдите дискриминант квадратного уравнения:y=5x^2+6x-7

Makson22 31 авг. 2014 г., 8:36:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ryabowairin
31 авг. 2014 г., 10:24:33 (9 лет назад)

#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    float a,b,c;
        int d;
        float x1, x2;

        cout << "ax^2+bx+c=0" << endl;
        cout << "Input a:" << endl;
        cin >> a;
        cout << "Input b:" << endl;
        cin >> b;
        cout << "Input c:" << endl;
        cin >> c;
        d= sqrt(b*b-4*a*c);
        x1=((-1)*b+d)/(2*a);
        x2=((-1)*b-d)/(2*a);
        cout << "x1=" << x1 << endl;
        cout << "x2=" << x2 << endl;
    return 0;
}

Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.


+ 0 -
Nastenkaalpha
31 авг. 2014 г., 13:05:42 (9 лет назад)

именно этого? или любого?

+ 0 -
Ir2004
31 авг. 2014 г., 15:46:53 (9 лет назад)

именно этого:(

+ 0 -
Ника73
31 авг. 2014 г., 16:34:24 (9 лет назад)

но можно любого тоже, я со своими числами сделаю

+ 0 -
Ahadovr
31 авг. 2014 г., 18:45:26 (9 лет назад)

хоть мне и лень, но я напишу.... минут 15-20

+ 0 -
Alinka0malinka
31 авг. 2014 г., 20:07:35 (9 лет назад)

спасибо огромное просто)

Ответить

Другие вопросы из категории

Помогите, пожалуйста, решить задачи в паскале :

1.Определите сколько нечетных чисел среди четырех заданных чисел
2.Вычислите, является ли четырехзначное число счастливым

Читайте также

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу



Вы находитесь на странице вопроса "Cоставить алгоритм и написать программу.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.