Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

составить блок схему алгоритма нахождения числа z

10-11 класс

Potran2023 16 сент. 2016 г., 4:34:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tonyaa
16 сент. 2016 г., 6:05:18 (7 лет назад)

var z,x:integer;
begin
readln(z);
if x>=4 then writeln(x-3);
if x<0 then writeln(sqr(x));
if (x>0) and (x<=4) then writeln(sqrt(x+1));
readln;
end.

Ответить

Другие вопросы из категории

Дан одномерный массив, сформировать из него двухмерный отсортированный змейкой: Начиная с правого нижнего угла вертикально. Pascal ABC

Вот код, только здесь выводится с левого угла, а мне нужно с правого:
uses crt;
var a:array [1..25] of integer;
ar:array [1..25,1..25] of integer;
i,n,s,j,x:integer;b:real;
L:boolean;
begin
write('n=');
readln(n);
writeln('Заполните массив:');
For i:=1 to n do readln(a[i]);
For i:=1 to n do
For j:=i+1 to n do
If a[i]>a[j] then begin
x:=a[i];
a[i]:=a[j];
a[j]:=x;
end;
s:=1;
writeln('Отсортированный массив: ');
For i:=1 to n do write(a[i], ' ');
writeln; b:=sqrt(n);
n:=round(b);
writeln('Двумерный массив: ');
for j:=1 to n do begin
for i:=1 to n do begin
ar[i,j]:=s;
if (j mod 2 = 0) and (i<>n) then dec(s)
else inc(s);
end;
s:=s+n-1;
end;
for i:=n downto 1 do begin
for j:=1 to n do write(ar[i,j]);
writeln;
end;
end.
Помогите пожалуйста

Помогите пожалуйста срочно нужно!!

массив целых чисел из 10 элементов заполнить случайным образом. упорядочить массив по возрастанию. подсчитать количество и произведение элементов массива, больших 20 и меньших 50, вывести полученный результат

Читайте также

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

Помогите решить, очень нужно... 2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных

элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10) количества положительных элементов.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.



Вы находитесь на странице вопроса "составить блок схему алгоритма нахождения числа z", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.