Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана матрица размера M × N. Найти

10-11 класс

минимальный среди элементов тех строк, которые упорядочены либо по
возрастанию, либо по убыванию. Если упорядоченные строки в матрице отсутствуют,
то вывести 0.

Laki2014 07 окт. 2016 г., 10:56:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aliimanvrdiev
07 окт. 2016 г., 12:37:38 (7 лет назад)

Задача № 1)
Код программы получился довольно таки большой , но можно сам файл *.pas Закинуть в интернет и оттуда скачать.
Задача №2)

uses crt;
var m:array[1..100,1..100] of integer;
    i,i1,j,str,stb,temp:integer;
begin
clrscr;
writeln('Пожалуйста введите число строк массива: '); readln(str);
writeln('Пожалуйста введите число Столбцов массива: '); readln(stb);
clrscr;
writeln('Массиа из ',str,' строк, и из ',stb,' столбцов успешно создан!');
writeln;
for i:=1 to str do
begin
     for j:=1 to stb do
     begin
     m[i,j]:=random(80)+1;
     write(m[i,j]:3,'  ');
     end;
     writeln;
end;
writeln;
writeln(' отсортирован по убыванию');
writeln;
for i1:=1  to str do
    for i:=1 to str-1 do
    for j:=i+1 to str do
    if m[i1,i]<m[i1,j] then begin temp:=m[i1,i]; m[i1,i]:=m[i1,j]; m[i1,j]:=temp;end;
writeln;
for i:=1 to str do
begin
     for j:=1 to stb do
     begin
     write(m[i,j]:3,'  ');
     end;
     writeln;
end;
readkey;
end.
Запускаешь водишь строк и столбцов после нажимаешь Enter программы сделает своё дело

Ответить

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Си++

Дана матрица размером Nстрок и Mстолбцов. Найти количество положительных чисел в столбце.



Вы находитесь на странице вопроса "Дана матрица размера M × N. Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.