Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой

10-11 класс

день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!

Shemari 26 апр. 2013 г., 16:10:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danilago
26 апр. 2013 г., 18:49:07 (10 лет назад)

а) 

var
i:integer;
p:real;
begin
i:=1;
p:=10;

repeat
p:=p + p*0.1;
i:=i+1;
until p>=20;
writeln(i, ' den');
end.

 

б)

var
i:integer;
p,n:real;
begin
i:=1;
p:=10;
n:=p;

repeat
n:=n+n*0.1;
p:=p + n;
i:=i+1;
write(n);
writeln(' ', p);
until p>=100;
writeln(i, ' den');
end.

Ответить

Другие вопросы из категории

Дана последовательность целых положительных чисел. Найти произведение только тех чисел, которые больше заданного числа М. Если таких нет выдать

сообщение об этом.

На Паскале.

Срочно, и пожалуйста, без заумных команд, а так чтобы понятно было!

помогите пожалуйста ответить на вопрос

Текст,
набранный в текстовом редакторе, хранится на внешнем запоминающем устройстве:
1) в виде файла
2) таблицы кодировки
3) каталога
4) папки

Читайте также

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Начав тренировки,спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь

пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.

Начав тренеровки,спортсмен в первый день пробежал 10 км.Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня.

Какой суммарный путь пробежит спортсмен за 7 дней?
В какой день впервые спортсмен пробежит более 20 км?
(написать программу на языке ПАСКАЛЯ)

Паскаль:

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько километров он пробежит в пятый день?



Вы находитесь на странице вопроса "Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.