Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста написать программу с двумерными массивами, которая выводит на экран то что, я добавил во вложение.

10-11 класс

Zhanell 30 дек. 2013 г., 5:04:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashamars00
30 дек. 2013 г., 7:30:54 (10 лет назад)

var
n, i, j, c : integer;
a : array [1..100, 1..100] of integer;
begin
readln (n);
for i := 1 to n do
a[1, i] := i;
for i := 2 to n do
begin
for j := i to n do
a[i, j - i + 1] := j;
for j := 1 to i - 1 do
a[i, n - i + j + 1] := j;
end;
for i := 1 to n do
begin
for j := 1 to n do
write (a[i, j], ' ');
writeln;
end;
readln;
end.

Ответить

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.




Вы находитесь на странице вопроса "Помогите пожалуйста написать программу с двумерными массивами, которая выводит на экран то что, я добавил во вложение.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.