Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

даны натуральные числа x и y. вычислите их НОК.задача для паскаля!помогите пожалуйста срочно надо

10-11 класс

ДумальщиК 08 февр. 2015 г., 1:40:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Arinalebedeva
08 февр. 2015 г., 2:53:26 (9 лет назад)

var x,y,nod,nok:longint;

 

begin

 

read(x,y);

 

a:=x; b:=y;

while (a>0) and (b>0) do

if a>b then a:=a mod b

else b:=b mod a;

nod:=a+b;

nok:=(x div nod)*y;

 

write(nok);

 

end;

Ответить

Другие вопросы из категории

8192 бит = ____ килобит = ____ килобайт?
N=20

Задание
1. Переведите (31
– N)Гбайт
в Мбайты, Кбайты, байты и биты, где N
– номер вашего варианта (порядковый
номер по списку в журнале).

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "даны натуральные числа x и y. вычислите их НОК.задача для паскаля!помогите пожалуйста срочно надо", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.