Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

помогите решить!

10-11 класс

Сколько различных решений имеет система
уравнений

Dimaci 30 авг. 2015 г., 9:22:50 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shukurova
30 авг. 2015 г., 11:50:56 (8 лет назад)

Каждое уравнение имеет вид
(A | B) & (~A | ~B) = 1
Отсюда следует, что
(A | B) = 1   и   (~A | ~B) = 1
Из первой скобки следует, что по крайней мере одно из высказываний А, В истинно. Из второй - что по крайней мере одно из высказываний ~A, ~B истинно. Поэтому ровно одно из высказываний A, B истинно, а другое ложно.
Пусть мы знаем x1, x2, x3, x5, x7, x9. Тогда остальные переменные определены однозначно: если x1=x2, то x4=~x3, x6=x5, x8=~x7, x10=x9; иначе всё наоборот.
Эти 6 переменных независимы, поэтому общее количество решений = количеству всевозможных наборов x1, x2, x3, x5, x7, x9 = 2^6 = 64

Ответить

Другие вопросы из категории

1)дан числовой массив из 10 чисел ( случайным образом) в интервале (50, 250) . Отсортировать массив.

2) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее арифметическое.
3) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.



Вы находитесь на странице вопроса "помогите решить!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.